summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-15 19:00:07 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-15 19:27:58 +0200
commita72fb4c3777386674ca2a5fa17a98922b3e3015a (patch)
tree70cee83fc0a5dc44bc774ec28a7baf3fe5282824 /dev-python
parentdev-python/mockredispy: Remove last-rited pkg (diff)
downloadgentoo-a72fb4c3777386674ca2a5fa17a98922b3e3015a.tar.gz
gentoo-a72fb4c3777386674ca2a5fa17a98922b3e3015a.tar.bz2
gentoo-a72fb4c3777386674ca2a5fa17a98922b3e3015a.zip
dev-python/parse: Remove last-rited pkg
Closes: https://bugs.gentoo.org/694280 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/parse/Manifest1
-rw-r--r--dev-python/parse/files/parse-1.6.6-python-3.5-tests-compat.patch50
-rw-r--r--dev-python/parse/metadata.xml9
-rw-r--r--dev-python/parse/parse-1.6.6.ebuild25
4 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/parse/Manifest b/dev-python/parse/Manifest
deleted file mode 100644
index 22f8fe25ddfa..000000000000
--- a/dev-python/parse/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST parse-1.6.6.tar.gz 24638 BLAKE2B dbf1844b09bfdd0fb8ebaecba14f4a6289de315f4d658eac4853696e11b32dc9cda5837ed654072941846f112b480315961d9660c7d111127f57aac8f2c30250 SHA512 fae467b6f6e35f04d9e501162117423506701d101b2265e941b5b34420e833a0f4dbc44f62c33d51836a62ef51da9b5b8a3a1d39b3ec490f9eb77c5b6f302cdf
diff --git a/dev-python/parse/files/parse-1.6.6-python-3.5-tests-compat.patch b/dev-python/parse/files/parse-1.6.6-python-3.5-tests-compat.patch
deleted file mode 100644
index 5183cf5ef32e..000000000000
--- a/dev-python/parse/files/parse-1.6.6-python-3.5-tests-compat.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 32f15cfefb7c7b6476360ac65cba807aa3dfccfa Mon Sep 17 00:00:00 2001
-From: David King <dking@redhat.com>
-Date: Mon, 14 Dec 2015 09:58:19 +0000
-Subject: [PATCH] Fix test_too_many_fields with Python 3.5
-
-Python versions before 3.5 had a limit of 100 groups in regular
-expressions. This limit was removed during 3.5 development:
-
-http://bugs.python.org/issue22437
-https://hg.python.org/cpython/rev/0b85ea4bd1af
-
-The test_too_many_fields test asserts that the limit exists by
-attempting to parse a string with 15 fields, which triggers the 100
-named groups limit.
-
-Adjust the test so that if first checks to see whether the limit of 100
-named groups exists, and only assert that parsing 15 fields fails if
-that is the case.
----
- test_parse.py | 10 ++++++++--
- 1 file changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/test_parse.py b/test_parse.py
-index c524349..1d50568 100755
---- a/test_parse.py
-+++ b/test_parse.py
-@@ -6,6 +6,7 @@
-
- import unittest
- from datetime import datetime, time
-+import re
-
- import parse
-
-@@ -624,8 +625,13 @@ def test_mixed_type_variant(self):
- self.assertEqual(r.fixed[21], 'spam')
-
- def test_too_many_fields(self):
-- p = parse.compile('{:ti}' * 15)
-- self.assertRaises(parse.TooManyFields, p.parse, '')
-+ # Python 3.5 removed the limit of 100 named groups in a regular expression,
-+ # so only test for the exception if the limit exists.
-+ try:
-+ re.compile("".join("(?P<n{n}>{n}-)".format(n=i) for i in range(101)))
-+ except AssertionError:
-+ p = parse.compile('{:ti}' * 15)
-+ self.assertRaises(parse.TooManyFields, p.parse, '')
-
-
- class TestSearch(unittest.TestCase):
diff --git a/dev-python/parse/metadata.xml b/dev-python/parse/metadata.xml
deleted file mode 100644
index 33e17f1c6c8a..000000000000
--- a/dev-python/parse/metadata.xml
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!--maintainer-needed-->
- <upstream>
- <remote-id type="pypi">parse</remote-id>
- <remote-id type="github">r1chardj0n3s/parse</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/parse/parse-1.6.6.ebuild b/dev-python/parse/parse-1.6.6.ebuild
deleted file mode 100644
index bb8a2ede0d4a..000000000000
--- a/dev-python/parse/parse-1.6.6.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="parse() is the opposite of format()"
-HOMEPAGE="https://github.com/r1chardj0n3s/parse"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-PATCHES=( "${FILESDIR}/${P}-python-3.5-tests-compat.patch" )
-
-python_test() {
- "${PYTHON}" test_parse.py || die "Tests failed under ${EPYTHON}"
-}