summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-02 11:52:20 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-02 13:22:38 +0200
commitc290c65870859551b38aa2c4d746b488208d106e (patch)
tree7991f6ff8e05c35eaf72d40ecb9bb5967d70aeef /dev-python
parentdev-python/qrcode: Bump to 8.0 (diff)
downloadgentoo-c290c65870859551b38aa2c4d746b488208d106e.tar.gz
gentoo-c290c65870859551b38aa2c4d746b488208d106e.tar.bz2
gentoo-c290c65870859551b38aa2c4d746b488208d106e.zip
dev-python/pyproj: Bump to 3.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyproj/Manifest1
-rw-r--r--dev-python/pyproj/pyproj-3.7.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pyproj/Manifest b/dev-python/pyproj/Manifest
index 1cf1895e0746..ca7e1759ede7 100644
--- a/dev-python/pyproj/Manifest
+++ b/dev-python/pyproj/Manifest
@@ -1 +1,2 @@
DIST pyproj-3.6.1.gh.tar.gz 239568 BLAKE2B e396e7c13dfc90f8a8eaf93b7bc0e62921779930d9c42b21ce8afa95597b13e527c179096600f40140d6d00d0f425580fccc34ae55a4e8c985d1b618554c9db4 SHA512 19c55e7ab99aae70bc318246146dc98ba75cc4884de798392f590df48c6a83e1b80504fd9c555ffd9d19262eb93cdf2c46e4805a3ae6dc07b3eaa4669f025ff0
+DIST pyproj-3.7.0.gh.tar.gz 240143 BLAKE2B e5508adbfe8f30ce6808bfeacfa8de0cd70ac2f7578aaffb3a3962aacd4cde0b7100645d562fe8822ab1d962b19c7c1d02bc336bc830058dac8a1995044adc9c SHA512 6cc1df752a5ca58b3a90a725ca113f52648e2bf72b4ecdd516169571f71652cee5c6b34bd4932b9ddf0b94b084ea4a406d915aebfa9abf1d4065567f7b48d660
diff --git a/dev-python/pyproj/pyproj-3.7.0.ebuild b/dev-python/pyproj/pyproj-3.7.0.ebuild
new file mode 100644
index 000000000000..9d26a37735d1
--- /dev/null
+++ b/dev-python/pyproj/pyproj-3.7.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to the PROJ library"
+HOMEPAGE="
+ https://github.com/pyproj4/pyproj/
+ https://pypi.org/project/pyproj/
+"
+SRC_URI="
+ https://github.com/pyproj4/pyproj/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux"
+
+DEPEND="
+ >=sci-libs/proj-9.0.0:=
+"
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/shapely[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # Avoid greedily trying -L/usr/lib, etc
+ # https://github.com/pyproj4/pyproj/blob/main/setup.py#L76
+ export PROJ_LIBDIR="${ESYSROOT}/usr/$(get_libdir)"
+ export PROJ_INCDIR="${ESYSROOT}/usr/include"
+}
+
+python_test() {
+ rm -rf pyproj || die
+ epytest -m "not network" test
+}