summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-16 07:32:23 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-16 08:46:44 +0200
commitcf81265acb8b6e6e9414fa4959d6d21087e7c512 (patch)
treefd1f75ae3021ab0bda79123290848b3613bfd2ff /dev-python
parentdev-python/cfn-lint: Bump to 0.86.3 (diff)
downloadgentoo-cf81265acb8b6e6e9414fa4959d6d21087e7c512.tar.gz
gentoo-cf81265acb8b6e6e9414fa4959d6d21087e7c512.tar.bz2
gentoo-cf81265acb8b6e6e9414fa4959d6d21087e7c512.zip
dev-python/markdown-exec: Bump to 1.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/markdown-exec/Manifest1
-rw-r--r--dev-python/markdown-exec/markdown-exec-1.8.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/markdown-exec/Manifest b/dev-python/markdown-exec/Manifest
index 623419c7a750..2330f4f46ba7 100644
--- a/dev-python/markdown-exec/Manifest
+++ b/dev-python/markdown-exec/Manifest
@@ -1 +1,2 @@
DIST markdown_exec-1.8.0.tar.gz 23164 BLAKE2B 8514c971baf5d989187f4ca0e2d0aae8c4f8799c10610a9cdcd3a5a47b24f97434889f887ad558a76e12288b9dde5f7dd82f2f8b955fdcd5909e2c5488e68ce2 SHA512 760c130cbdbcc5eeb9d8b885c1bbea04452624caa795a2f05d804463de9ead1fb20c919761e27580e6f60f6844b3ce2f8c19ec97a07fb3addc4558968ef4f11a
+DIST markdown_exec-1.8.1.tar.gz 23205 BLAKE2B 410d4ffc40ddc9393cd24f22a9f2aff436f24b5339d03c7645b3d962ff76aff40badaa0dfa4dd60d30fb43223924688d80fd1bd4667231a7362074653fd5a2b1 SHA512 57b786afb952558053798f8fc1cb9f4086f47d4e5ac8164591304b6789057b75918532e73e232314c01abb2203135382afcd8d8e759f2402852d1cb794f64d77
diff --git a/dev-python/markdown-exec/markdown-exec-1.8.1.ebuild b/dev-python/markdown-exec/markdown-exec-1.8.1.ebuild
new file mode 100644
index 000000000000..a80628fef998
--- /dev/null
+++ b/dev-python/markdown-exec/markdown-exec-1.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Utilities to execute code blocks in Markdown files"
+HOMEPAGE="
+ https://pawamoy.github.io/markdown-exec/
+ https://pypi.org/project/markdown-exec/
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+IUSE="ansi"
+
+RDEPEND="
+ >=dev-python/pymdown-extensions-9[${PYTHON_USEDEP}]
+ ansi? (
+ dev-python/pygments-ansi-color[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest