summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-11-11 13:00:39 +0100
committerMichał Górny <mgorny@gentoo.org>2018-11-11 13:03:26 +0100
commitdabeaaae0d1b2fd91c90f05a70ff79cb19ca7825 (patch)
tree3cbbcc50b044d81b237c5a4f2e56a858d118f7fb /dev-python
parentmedia-gfx/asymptote: bump to 2.47 (diff)
downloadgentoo-dabeaaae0d1b2fd91c90f05a70ff79cb19ca7825.tar.gz
gentoo-dabeaaae0d1b2fd91c90f05a70ff79cb19ca7825.tar.bz2
gentoo-dabeaaae0d1b2fd91c90f05a70ff79cb19ca7825.zip
dev-python/flask-testing: Remove last-rited pkg
Closes: https://bugs.gentoo.org/285169 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flask-testing/Manifest2
-rw-r--r--dev-python/flask-testing/files/0.4.2-test-fix.patch17
-rw-r--r--dev-python/flask-testing/flask-testing-0.4.2.ebuild35
-rw-r--r--dev-python/flask-testing/flask-testing-0.6.2.ebuild40
-rw-r--r--dev-python/flask-testing/metadata.xml13
5 files changed, 0 insertions, 107 deletions
diff --git a/dev-python/flask-testing/Manifest b/dev-python/flask-testing/Manifest
deleted file mode 100644
index 1be39ac997e3..000000000000
--- a/dev-python/flask-testing/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST Flask-Testing-0.4.2.tar.gz 40994 BLAKE2B a3d5d5d50598586afde1d4b0f6452919db5c84ed1615ca2b83312f24d04835abd8552bb0d7b3f8c6e03a8664bbd49cf157bc7c2ec935bd6143bfab4584dd4981 SHA512 57f1a58f352637b6c1d4dc5aa8b3cac215eae334f355d40b6c777f9c5a769c745ce11f2a98818669ec2c29fc170fd86fe4670bb66bd4e4607174b21c5c2067e3
-DIST Flask-Testing-0.6.2.tar.gz 129078 BLAKE2B 099444b21d68a23816edcb7ad55d03080017839ea57334f6a4fc63ab3c3ed9b09ef5989b112fdd41a3180f37a70a3481986068d6e7c8304c1bf8fa01ecd6c277 SHA512 1ce6a32f2c4e2d6d39c0bd2f01b8d20e2ee8faa5cb31d308bbcda2159f8307cc42f445e328a3752c3c3c66f4fffef75b400c70954b1aeb1aabab8a54c565b5ce
diff --git a/dev-python/flask-testing/files/0.4.2-test-fix.patch b/dev-python/flask-testing/files/0.4.2-test-fix.patch
deleted file mode 100644
index a0933e475afc..000000000000
--- a/dev-python/flask-testing/files/0.4.2-test-fix.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-https://github.com/jarus/flask-testing/commit/c969b41b31f60a5a8bacd44b3eb63d1642f2d8bf
-diff --git a/flask_testing/utils.py b/flask_testing/utils.py
-index add12ef..9b479df 100644
---- a/flask_testing/utils.py
-+++ b/flask_testing/utils.py
-@@ -143,8 +143,8 @@ def _post_teardown(self):
-
- if _is_signals:
- template_rendered.disconnect(self._add_template)
-- if hasattr(self, '_true_render'):
-- templating._render = self._true_render
-+ if hasattr(self, '_original_template_render'):
-+ templating._render = self._original_template_render
-
- if self.run_gc_after_test:
- gc.collect()
-
diff --git a/dev-python/flask-testing/flask-testing-0.4.2.ebuild b/dev-python/flask-testing/flask-testing-0.4.2.ebuild
deleted file mode 100644
index 87258db25a41..000000000000
--- a/dev-python/flask-testing/flask-testing-0.4.2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
-
-inherit distutils-r1
-
-MY_PN="Flask-Testing"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Unit testing for Flask"
-HOMEPAGE="https://pythonhosted.org/Flask-Testing/ https://pypi.org/project/Flask-Testing/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/twill[${PYTHON_USEDEP}]' python2_7)"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/blinker[${PYTHON_USEDEP}]
- )"
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}"/${PV}-test-fix.patch )
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/flask-testing/flask-testing-0.6.2.ebuild b/dev-python/flask-testing/flask-testing-0.6.2.ebuild
deleted file mode 100644
index a171d4354470..000000000000
--- a/dev-python/flask-testing/flask-testing-0.6.2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1
-
-MY_PN="Flask-Testing"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Unit testing for Flask"
-HOMEPAGE="https://pythonhosted.org/Flask-Testing/ https://pypi.org/project/Flask-Testing/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/twill[${PYTHON_USEDEP}]' 'python2*')"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- local exclude
- if $(python_is_python3); then
- # Twill is not available on python-3
- exclude="-e twill"
- fi
- # test phase appears to run only py2.7 but if it passes for py2.7 is passes for pypy
- nosetests ${exclude} || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/flask-testing/metadata.xml b/dev-python/flask-testing/metadata.xml
deleted file mode 100644
index 186145be8e10..000000000000
--- a/dev-python/flask-testing/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">Flask-Testing</remote-id>
- <remote-id type="github">jarus/flask-testing</remote-id>
- <bugs-to>https://github.com/jarus/flask-testing/issues</bugs-to>
- </upstream>
-</pkgmetadata>