summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-20 02:49:55 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-20 03:29:17 +0200
commitdaf20ebbf696e83a8af04387af35eca11756b11e (patch)
treed1aaedc36a9b9102f08f02cb2440dbfe0e86d83d /dev-python
parentdev-python/setuptools: Bump to 73.0.0 (diff)
downloadgentoo-daf20ebbf696e83a8af04387af35eca11756b11e.tar.gz
gentoo-daf20ebbf696e83a8af04387af35eca11756b11e.tar.bz2
gentoo-daf20ebbf696e83a8af04387af35eca11756b11e.zip
dev-python/ensurepip-setuptools: Bump to 73.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ensurepip-setuptools/Manifest1
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-73.0.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/Manifest b/dev-python/ensurepip-setuptools/Manifest
index 26548197729e..1262c8f74162 100644
--- a/dev-python/ensurepip-setuptools/Manifest
+++ b/dev-python/ensurepip-setuptools/Manifest
@@ -1,2 +1,3 @@
DIST setuptools-72.1.0-py3-none-any.whl 2337965 BLAKE2B 88954b396a47b4223b73313100b9ae0782a16f755660da1abed31316f056beca78401b151f1bec39a791b1c556da09479e527b2316f5d1391e6996f5433c0bc3 SHA512 ef9f855c8ca4d7f6e5eb79f3d40b44830eede4664ec5667415fc676a0b8230a64fb62fda49c1eef6a9c3f89d4724b0717e7d702be99ab61f8763d91feb9a6ea1
DIST setuptools-72.2.0-py3-none-any.whl 2336658 BLAKE2B d46adb6be347ee6107ca90850ad1c8df60723e1cb93e402b53c02316a07b7cb71dd8d657cb3beb8c926fa23308d4e8fca7221b52e5f59fbfa744d6758b603343 SHA512 e7730427e7ff342a52f638fe1d457cdb906971f33dd87bb01a26b2d01b134f561397b7a6ffbe078ba5867306ba14bd8316995ab823f9b1c806646c2f242209c6
+DIST setuptools-73.0.0-py3-none-any.whl 2346506 BLAKE2B e01e9cb1bd9d3800379be49f4a5f0066708433f98758715e56c61bbd6ea342e18274305ed7279415f5b9dd70484dbdf1736b34f9f0482768a0d964011d3bfa88 SHA512 e4548bc7c6b1ee752ac919bf970050e1b6017548719e406ab6af59221c743ece9048ac16b0c1affc3f9da5e0444d4ee522bcd09e60f42044ceaacac2cf8c9cf4
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-73.0.0.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-73.0.0.ebuild
new file mode 100644
index 000000000000..97aca4a61872
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-73.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pypi
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${A}"
+}