summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-11 13:24:55 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-11 18:19:25 +0200
commitecdd654058a46764665f067818cb0fbc037c1ff0 (patch)
tree5483d4e854ab71031defa8e91ed6440be14b8b30 /dev-python
parentdev-python/aiohttp-cors: Drop old (diff)
downloadgentoo-ecdd654058a46764665f067818cb0fbc037c1ff0.tar.gz
gentoo-ecdd654058a46764665f067818cb0fbc037c1ff0.tar.bz2
gentoo-ecdd654058a46764665f067818cb0fbc037c1ff0.zip
dev-python/doit: Drop old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/doit/Manifest1
-rw-r--r--dev-python/doit/doit-0.23.0-r1.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/doit/Manifest b/dev-python/doit/Manifest
index fa133d9b9573..d8214a7a17a0 100644
--- a/dev-python/doit/Manifest
+++ b/dev-python/doit/Manifest
@@ -1,2 +1 @@
-DIST doit-0.23.0.tar.gz 316588 BLAKE2B c7c2edc3e38e60bf4cdf6bd7eae4f65606da3168e3def4710ef0a2e07fe9c9c70b5555bfc1b2858f3536ba2ff3a9b8624353d1bf8b1ed8901f76a2cd5f32ae9b SHA512 f2298d76d9ce3e7ed5f356bfdeeef8d5d99ebae74571666a3d2b3843fc63f5a8f76cd6cdedcfe8fc81bc653ecf04951c11f50abd16e9aa8fc7539e3c224b0e4c
DIST doit-0.29.0.tar.gz 222341 BLAKE2B 8489568fe9236af04f87debfb4889840aa162d17d20f82ac0a9a22d1034b4c58976cd6829486a15b941ac1f50e7137c052fe332657c2b3f529fe2345bbcba2fc SHA512 a686457df31b414d0c3797789e0ae1ae5cdfa3674025236419cb59b254f342cd2db07911ef18b2cb576d8d817b44035b9372265b34b786b2779fb7074b394de1
diff --git a/dev-python/doit/doit-0.23.0-r1.ebuild b/dev-python/doit/doit-0.23.0-r1.ebuild
deleted file mode 100644
index d3f06af7c264..000000000000
--- a/dev-python/doit/doit-0.23.0-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-inherit eutils distutils-r1
-
-DESCRIPTION="Automation tool"
-HOMEPAGE="http://python-doit.sourceforge.net/ https://pypi.org/project/doit/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="test"
-
-RDEPEND="dev-python/pyinotify[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-# Required for test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-DOCS=( AUTHORS CHANGES README TODO.txt dev_requirements.txt )
-
-python_prepare_all() {
- use test && DISTUTILS_IN_SOURCE_BUILD=1
- # Tests of this file fail due to setting of a tmp dir which can be fixed.
- # This known spurious cause does not warrant halting a testsuite
- rm -f tests/test_cmd_strace.py || die
-
- # These 2 tests succeed on running the suite a second time, so they are NOT broken
- # A gentoo test phase is run only once, so these unbroken tests can be safely skipped.
- sed -e s':testInit:_&:' -e s':testLoop:_&:' \
- -i tests/test_filewatch.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Testsuite is designed to be run by py.test, called by runtests.py
- # https://bitbucket.org/schettino72/doit/issue/78/tests-that-fail-under-pypy
- if [[ "${EPYTHON}" == pypy-c2.0 ]]; then
- sed -e 's:test_corrupted_file:_&:' \
- -e 's:test_corrupted_file_unrecognized_excep_pdep:_&:' \
- -i tests/test_dependency.py || die
- elif [[ "${EPYTHON}" == python2.6 ]]; then
- rm -f tests/test___main__.py || die
- sed -e 's:test_invalid_param_stdout:_&:' \
- -i tests/test_action.py || die
- sed -e 's:test_run_wait:_&:' \
- -i tests/test_cmd_auto.py || die
- fi
- "${PYTHON}" runtests.py
-}
-
-src_install() {
- distutils-r1_src_install
-
- dodoc -r doc
- docompress -x /usr/share/doc/${PF}/doc
-}