summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-29 05:11:37 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-29 05:58:47 +0200
commitf4820325d2970f82cf6f1c2184f6e08034d147ab (patch)
tree2424b03a37b7e239b6ca1664242d630dddabbc90 /dev-python
parentdev-python/botocore: Bump to 1.31.36 (diff)
downloadgentoo-f4820325d2970f82cf6f1c2184f6e08034d147ab.tar.gz
gentoo-f4820325d2970f82cf6f1c2184f6e08034d147ab.tar.bz2
gentoo-f4820325d2970f82cf6f1c2184f6e08034d147ab.zip
dev-python/boto3: Bump to 1.28.36
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.28.36.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 7fe7a8e5efbd..f8efeaeee63e 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -11,3 +11,4 @@ DIST boto3-1.28.32.gh.tar.gz 690385 BLAKE2B 2d5ff74dc8f27d43329796910c6810257f99
DIST boto3-1.28.33.gh.tar.gz 690686 BLAKE2B 572f5aa0b9a71e39a62fccdce84fa359e0b96d196d983965d335de2299e734239586bfde43c5f48463afddace7d7a91139cabc2737a5b4f3b40684c13112f267 SHA512 2bb4375f5c3d85283a10ff9325b8688ab1e2aceb7be8cd255bc2d054c75eda54df320a85eb4910e0119633e8977158f216df2fdb373c9bb5df8eb7cb4389a4fd
DIST boto3-1.28.34.gh.tar.gz 692262 BLAKE2B e6382326f74f05c045a3ecacedbef2917dc297343637a70d4947b20b37a33e303bbf751b1f55d7deae581788a0ac2a627b3fdd58629b3ad961030e6095c1eb90 SHA512 340352632d1058d7ed50ce011d2697ed01680d6ee0443fe6fa08813924deffc642d6ec0b076bf9669a98e926fb5467a546ff3c4febe43eec602ab1f2cd51e8d3
DIST boto3-1.28.35.gh.tar.gz 692481 BLAKE2B fe5c5906598be2aaef8524a0333751bc2368aa33a3c212d45d95b1010f15d228b4b617ad7e855d668f38b9278c32bafc7c5da4395582a053ae3350d4c5453c7b SHA512 790fcb6a0aac9ae37d3d04c707b05d44249b7e265e47ad8fd9195ec338f70297b018f4d3ef34cd704fc3d82564794ea7fb4e5e9057cbae4a969d220eb911981f
+DIST boto3-1.28.36.gh.tar.gz 693285 BLAKE2B 9d25f49ecb213c8f273fff908a125373d6558244dbf03cf716bf871a565ec0a71aa7330af0f64111f4a6191654cacb1c2c60566fb9fd2540aa8df3e4c442e0b9 SHA512 b2ee0a647d9863d251dc613550d10a83f60b0513407d7507b4ef4c9db0aa13e6feb9a24c4f93200553b61d756fb3cef417f43203cb71f3839ed66aae6183af91
diff --git a/dev-python/boto3/boto3-1.28.36.ebuild b/dev-python/boto3/boto3-1.28.36.ebuild
new file mode 100644
index 000000000000..ec9fc93bf23a
--- /dev/null
+++ b/dev-python/boto3/boto3-1.28.36.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --dist=worksteal
+}