summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-13 07:36:35 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-13 07:55:13 +0100
commitf6ad276d42233b81e8ed1300a27730dabcb6e473 (patch)
treefe304a57adacdb4b09ef70b8a7d8fdd486cbe994 /dev-python
parentdev-python/pydantic-core: Bump to 2.27.0 (diff)
downloadgentoo-f6ad276d42233b81e8ed1300a27730dabcb6e473.tar.gz
gentoo-f6ad276d42233b81e8ed1300a27730dabcb6e473.tar.bz2
gentoo-f6ad276d42233b81e8ed1300a27730dabcb6e473.zip
dev-python/sybil: Bump to 9.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-9.0.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index deec8d4ec70f..c991c541e688 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,2 +1,3 @@
DIST sybil-8.0.0.gh.tar.gz 75118 BLAKE2B f62f15dab48af23423d8ce9e8a49f3b772fad7d029360d0a98f36a8d2386fc2fc76a2510550ada6b2256848364fa0c998ba939f625c00f1628b8d1a07ad298b5 SHA512 00a02c786e29596fadc3f016c97bc492723fdd956b430ddca2a5e66d38cab424410cf3c74b46f5fff84d3bf3d39ba397068562c5bdca3cff142ce42ad0048487
DIST sybil-8.0.1.gh.tar.gz 75321 BLAKE2B dc3b4dcafd7d10549d75767a86a32d6509c1fc6683617d533b64bedb9499dfa1405656eed049622d32d9aef13f74e20ba2a46bf5eb57bd8306e086a31353b2cb SHA512 06f0012198e575c0a90274c970880c5fbbcf0738ea57a4cc9692999ea3ad9e40be217e741b3b6ddcfd947f1787c3d60e68ee4d52d547f9929cf3fd2c89880bcc
+DIST sybil-9.0.0.gh.tar.gz 75154 BLAKE2B adc04da47539cb17001538776f1b73c2a27eae07fcc63ace38925fb46e2679f21133354b78da02299d9f87d047d68ee4ba623fc555c9efd17e965a067e8c8646 SHA512 098efe001c17606cbf3ab4095ca9b85e784a13af67d48d898a2622c18c6a506507ba7dddd43a232bb8c270734b9fadb24aeff356833a854a45285521a06c3ed8
diff --git a/dev-python/sybil/sybil-9.0.0.ebuild b/dev-python/sybil/sybil-9.0.0.ebuild
new file mode 100644
index 000000000000..6244e3506d0c
--- /dev/null
+++ b/dev-python/sybil/sybil-9.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}