summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-06 09:26:54 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-06 11:59:01 +0100
commitfedd60be672a7cf07c9b88f4fe712a879f10ca1f (patch)
treeb9e8dae8cb7c7e6d433446c25c154a53232009aa /dev-python
parentdev-python/hypothesis: Bump to 6.24.2 (diff)
downloadgentoo-fedd60be672a7cf07c9b88f4fe712a879f10ca1f.tar.gz
gentoo-fedd60be672a7cf07c9b88f4fe712a879f10ca1f.tar.bz2
gentoo-fedd60be672a7cf07c9b88f4fe712a879f10ca1f.zip
dev-python/fonttools: Bump to 4.28.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.28.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index ff9d99cdb7ae..a4797d93ee6c 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,2 +1,3 @@
DIST fonttools-4.26.2.tar.gz 2579391 BLAKE2B 35a2533a336498aa1d5b9c2a61c1de6af03e6a7a1932a1ad71522f7f73e52590c347fe3e7d60b93b013389023792e6e6b91d6b4bfb92e007062dc2ac494adbb6 SHA512 2caa52a48574e6bdf418fe57fb4ca69686eeae65cb1f44c0cb16c64400ea666530dfcca9e8a619859cf553435f93b38f63e422c315206ecec467eed6339a5987
DIST fonttools-4.27.1.tar.gz 2645747 BLAKE2B aea6b8c13f29f460945f2d075176960f0f994fc262af06b493d2c34a0e4e6d37263f642e6ebb44b4a7c082bdcd7d4f1fa88e40e82760cf8a9b90cab8735f005a SHA512 76371a1244cb1c681b90f31ce67de3aff5e732477aea02c046a45a838ed49f097707edd359c7427e2643b357c12f6516d667d6b1a61e942a8e3b57eae1d6df70
+DIST fonttools-4.28.0.tar.gz 2654535 BLAKE2B 2bdde1a5c9184574e220bf3fa5dea04ae0e4ab8bb85bb8893e38e96cd028dc6cdcb88b21a9d12429292fe9cb282a90ce7b3abf4f17dea95df52165f5f4d0da0c SHA512 6fddef1d065001afd63147fc474c49f7799895aafddb37b3c94e981fa86e829b39865a40c61e3bf1e64f64a40cf4d5ae02fa98fcf7c89d3f893a2588d213427d
diff --git a/dev-python/fonttools/fonttools-4.28.0.ebuild b/dev-python/fonttools/fonttools-4.28.0.ebuild
new file mode 100644
index 000000000000..b98e2fa9734d
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.28.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=dev-python/fs-2.4.9[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ DISTUTILS_ARGS=( --with-cython )
+}
+
+python_test() {
+ distutils_install_for_testing
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx epytest Tests fontTools
+}