summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-29 05:07:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-29 05:16:26 +0200
commitff59c5b356f843a825953677abddbbd1586646cb (patch)
tree4acc9d94279a1420213717b9c952e3e66345b27a /dev-python
parentdev-python/sphinxcontrib-applehelp: Bump to 2.0.0 (diff)
downloadgentoo-ff59c5b356f843a825953677abddbbd1586646cb.tar.gz
gentoo-ff59c5b356f843a825953677abddbbd1586646cb.tar.bz2
gentoo-ff59c5b356f843a825953677abddbbd1586646cb.zip
dev-python/sphinxcontrib-devhelp: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinxcontrib-devhelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-2.0.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-devhelp/Manifest b/dev-python/sphinxcontrib-devhelp/Manifest
index 09b7c2a72faf..6cc9d445d49d 100644
--- a/dev-python/sphinxcontrib-devhelp/Manifest
+++ b/dev-python/sphinxcontrib-devhelp/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib_devhelp-1.0.6.tar.gz 12480 BLAKE2B 40fcbd13156cba5d904ee30e98284f0bc6f53e4dc2003cbeca6cb0189122d8b453ca7ab849570bbea615a2b0d4fc016b1ff6f72b2f8ec337b9424b4fc9ff8a57 SHA512 97ab48f4adc16140323220bd23447d74fdec1d223e64c06a325df9568436bbce31edf5b33103dc81e0eb937f7ac8328b012fce80d2d6fd995dc0f63e9fb15f77
+DIST sphinxcontrib_devhelp-2.0.0.tar.gz 12967 BLAKE2B b99418693db6b1d3466b18025c6d2be73d4a567419454905642ccc805f34292df1bb6b69a8f39b6a48ed3335fc61a59d9e5a08e65909885b9facbcc90937fcc5 SHA512 72d0bef99f46422160e54053e2594f04a90cd5bc0d8a7ce51259e013472fb9b5102dd87a2807771455d04ceceea94df5fd77cea08e922688f70b62630087083e
diff --git a/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-2.0.0.ebuild b/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-2.0.0.ebuild
new file mode 100644
index 000000000000..74fb38077fc0
--- /dev/null
+++ b/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-2.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs Devhelp documents"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-devhelp/
+ https://pypi.org/project/sphinxcontrib-devhelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest