summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-10-14 18:30:50 +0300
committerSam James <sam@gentoo.org>2022-11-02 05:09:45 +0000
commitc2b15ca2f28c0decd82dff7167b73a455ac1c7b1 (patch)
tree12faa77e4e5a7d7972c14606fab54d457d2ea6a8 /dev-qt/qttools
parentqt6-build.eclass: add qt6-build_src_install (diff)
downloadgentoo-c2b15ca2f28c0decd82dff7167b73a455ac1c7b1.tar.gz
gentoo-c2b15ca2f28c0decd82dff7167b73a455ac1c7b1.tar.bz2
gentoo-c2b15ca2f28c0decd82dff7167b73a455ac1c7b1.zip
dev-qt/*: add version 6.4.0
Bug: https://bugs.gentoo.org/838970 Bug: https://bugs.gentoo.org/863224 Bug: https://bugs.gentoo.org/875956 Closes: https://bugs.gentoo.org/862525 Closes: https://bugs.gentoo.org/863395 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/27812 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-qt/qttools')
-rw-r--r--dev-qt/qttools/Manifest1
-rw-r--r--dev-qt/qttools/files/qttools-6.4.0-clang-15-build.patch73
-rw-r--r--dev-qt/qttools/qttools-6.4.0.ebuild55
3 files changed, 129 insertions, 0 deletions
diff --git a/dev-qt/qttools/Manifest b/dev-qt/qttools/Manifest
index 229a67e4b708..4c16602d8ca0 100644
--- a/dev-qt/qttools/Manifest
+++ b/dev-qt/qttools/Manifest
@@ -1 +1,2 @@
DIST qttools-everywhere-src-6.3.2.tar.xz 8629400 BLAKE2B 594f7f31e0f10006d1c58d26c5ae13b7f9c8b5770adaddee90a176676dff2029215501d01d599da0656876cd6f8b97275754a9b8c37735412154ca3f458656b3 SHA512 ca8b11dac82027979ff9b17b8beb50ea316cba6d8f422a291caa63a4f7c345942bf852733fd7243a27bcf46b1ca6a5af30e283377a8c6b73193004e3aa3837f1
+DIST qttools-everywhere-src-6.4.0.tar.xz 8738432 BLAKE2B 0bd6c3e1e4badf16ec74209c1ddc45820bee9403753b6603000fcad8e82b5ee73b4df0f4d346de5c855e0b545e43c17b11ba5702e9caa5b8b2e6280d82a3fab5 SHA512 ff4ed95491d26227b3bfea665fe810572f537a295dda0cffa26b18525961026db0471e7ef04667e3e4b8ae6b92dbedccb0fa77d733274c34d489d448b961ab44
diff --git a/dev-qt/qttools/files/qttools-6.4.0-clang-15-build.patch b/dev-qt/qttools/files/qttools-6.4.0-clang-15-build.patch
new file mode 100644
index 000000000000..eb2d8027cc09
--- /dev/null
+++ b/dev-qt/qttools/files/qttools-6.4.0-clang-15-build.patch
@@ -0,0 +1,73 @@
+Gentoo Bug: https://bugs.gentoo.org/873640
+Qt Bug: https://bugreports.qt.io/browse/QTBUG-106224
+Patch: https://codereview.qt-project.org/c/qt/qttools/+/436135
+
+From 6495329e6de803025e6e4e8291b648f94893551c Mon Sep 17 00:00:00 2001
+From: =?utf8?q?Bj=C3=B6rn=20Sch=C3=A4pers?= <bjoern@hazardy.de>
+Date: Sat, 1 Oct 2022 07:19:52 +0200
+Subject: [PATCH] lupdate: Fix build with clang 15+
+MIME-Version: 1.0
+Content-Type: text/plain; charset=utf8
+Content-Transfer-Encoding: 8bit
+
+The signature of InclusionDirective changed for clang 15.
+
+Pick-to: 6.4
+Change-Id: Ic259b3508088671b40f6f615524137ce8837c487
+Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io>
+---
+ src/linguist/lupdate/lupdatepreprocessoraction.cpp | 13 +++++++++++--
+ src/linguist/lupdate/lupdatepreprocessoraction.h | 7 ++++++-
+ 2 files changed, 17 insertions(+), 3 deletions(-)
+
+diff --git a/src/linguist/lupdate/lupdatepreprocessoraction.cpp b/src/linguist/lupdate/lupdatepreprocessoraction.cpp
+index abfab34e5c..d963747d8e 100644
+--- a/src/linguist/lupdate/lupdatepreprocessoraction.cpp
++++ b/src/linguist/lupdate/lupdatepreprocessoraction.cpp
+@@ -156,14 +156,23 @@ void LupdatePPCallbacks::SourceRangeSkipped(clang::SourceRange sourceRange,
+ // To list the included files
+ void LupdatePPCallbacks::InclusionDirective(clang::SourceLocation /*hashLoc*/,
+ const clang::Token & /*includeTok*/, clang::StringRef /*fileName*/, bool /*isAngled*/,
+- clang::CharSourceRange /*filenameRange*/, const clang::FileEntry *file,
++ clang::CharSourceRange /*filenameRange*/,
++#if (LUPDATE_CLANG_VERSION >= LUPDATE_CLANG_VERSION_CHECK(15,0,0))
++ const clang::Optional<clang::FileEntryRef> file,
++#else
++ const clang::FileEntry *file,
++#endif
+ clang::StringRef /*searchPath*/, clang::StringRef /*relativePath*/,
+ const clang::Module */*imported*/, clang::SrcMgr::CharacteristicKind /*fileType*/)
+ {
+ if (!file)
+ return;
+
+- clang::StringRef fileNameRealPath = file->tryGetRealPathName();
++ clang::StringRef fileNameRealPath = file->
++#if (LUPDATE_CLANG_VERSION >= LUPDATE_CLANG_VERSION_CHECK(15,0,0))
++ getFileEntry().
++#endif
++ tryGetRealPathName();
+ if (!LupdatePrivate::isFileSignificant(fileNameRealPath.str()))
+ return;
+
+diff --git a/src/linguist/lupdate/lupdatepreprocessoraction.h b/src/linguist/lupdate/lupdatepreprocessoraction.h
+index b1ee468d4e..3e44cee839 100644
+--- a/src/linguist/lupdate/lupdatepreprocessoraction.h
++++ b/src/linguist/lupdate/lupdatepreprocessoraction.h
+@@ -51,7 +51,12 @@ private:
+ void SourceRangeSkipped(clang::SourceRange sourceRange, clang::SourceLocation endifLoc) override;
+ void InclusionDirective(clang::SourceLocation /*hashLoc*/, const clang::Token &/*includeTok*/,
+ clang::StringRef /*fileName*/, bool /*isAngled*/,
+- clang::CharSourceRange /*filenameRange*/, const clang::FileEntry *file,
++ clang::CharSourceRange /*filenameRange*/,
++#if (LUPDATE_CLANG_VERSION >= LUPDATE_CLANG_VERSION_CHECK(15,0,0))
++ const clang::Optional<clang::FileEntryRef> file,
++#else
++ const clang::FileEntry *file,
++#endif
+ clang::StringRef /*searchPath*/, clang::StringRef /*relativePath*/,
+ const clang::Module */*imported*/,
+ clang::SrcMgr::CharacteristicKind /*fileType*/) override;
+--
+2.16.3
+
diff --git a/dev-qt/qttools/qttools-6.4.0.ebuild b/dev-qt/qttools/qttools-6.4.0.ebuild
new file mode 100644
index 000000000000..6aa7cb05da97
--- /dev/null
+++ b/dev-qt/qttools/qttools-6.4.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt Tools Collection"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="
+ assistant designer distancefieldgenerator +linguist pixeltool
+ qdbus qdoc qtattributionsscanner qtdiag qtplugininfo
+"
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*[network]
+ assistant? ( =dev-qt/qtbase-${PV}*[sql,widgets] )
+ designer? ( =dev-qt/qtbase-${PV}*[widgets] )
+ distancefieldgenerator? (
+ =dev-qt/qtbase-${PV}*[widgets]
+ =dev-qt/qtdeclarative-${PV}*
+ )
+ pixeltool? ( =dev-qt/qtbase-${PV}*[widgets] )
+ qdbus? ( =dev-qt/qtbase-${PV}*[widgets] )
+ qdoc? ( sys-devel/clang:= )
+ qtdiag? ( =dev-qt/qtbase-${PV}*[opengl,widgets] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-6.4.0-clang-15-build.patch" # Bug 873640
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature assistant)
+ -DQT_FEATURE_commandlineparser=ON
+ $(qt_feature designer)
+ $(qt_feature distancefieldgenerator)
+ $(qt_feature linguist)
+ $(qt_feature pixeltool)
+ $(qt_feature qdbus)
+ $(qt_feature qdoc clang)
+ $(qt_feature qtattributionsscanner)
+ $(qt_feature qtdiag)
+ $(qt_feature qtplugininfo)
+ -DQT_FEATURE_thread=ON
+ )
+
+ qt6-build_src_configure
+}