summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-02 08:06:33 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-02 09:05:05 -0400
commitb171a3709e66806172483b1ed65202fa256a3ad6 (patch)
tree8d2dca2271bb6c2f88583d7017db70b05821a5a5 /dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0.ebuild
parentdev-qt/qttranslations: add 6.7.0 (diff)
downloadgentoo-b171a3709e66806172483b1ed65202fa256a3ad6.tar.gz
gentoo-b171a3709e66806172483b1ed65202fa256a3ad6.tar.bz2
gentoo-b171a3709e66806172483b1ed65202fa256a3ad6.zip
dev-qt/qtvirtualkeyboard: add 6.7.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0.ebuild')
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0.ebuild
new file mode 100644
index 000000000000..098c09ea6c42
--- /dev/null
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Customizable input framework and virtual keyboard for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~loong ~riscv ~x86"
+fi
+
+IUSE="+spell"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtsvg-${PV}:6
+ spell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature spell hunspell)
+ -DINPUT_vkb_handwriting=no # neither cerence nor myscript are packaged
+ )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # rarely randomly(?) fails even with -j1
+ tst_layoutfilesystem
+ )
+
+ if use spell && has_version app-dicts/myspell-en; then
+ # 99% pass but minor sub-tests fail with myspell-en, needs looking into
+ ewarn "Warning: notable tests were skipped due to ${_} being installed"
+ CMAKE_SKIP_TESTS+=(
+ tst_inputpanel
+ tst_inputpanelcontrols2
+ )
+ else
+ einfo "tst_inputpanel can take >5mins, not known to actually hang"
+ fi
+
+ qt6-build_src_test
+}