summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-18 13:43:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-18 15:40:02 +0200
commitfa0506d4d1f17ba81fd999919d64bbbfb14e1279 (patch)
treebc17db86a5b5ad539adcc59ea0aaf9fc5639974c /dev-qt/qtwebchannel
parentmedia-video/vlc: Add USE=srt (diff)
downloadgentoo-fa0506d4d1f17ba81fd999919d64bbbfb14e1279.tar.gz
gentoo-fa0506d4d1f17ba81fd999919d64bbbfb14e1279.tar.bz2
gentoo-fa0506d4d1f17ba81fd999919d64bbbfb14e1279.zip
dev-qt: Add Qt 5.11.0_rc2
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'dev-qt/qtwebchannel')
-rw-r--r--dev-qt/qtwebchannel/Manifest1
-rw-r--r--dev-qt/qtwebchannel/qtwebchannel-5.11.0_rc2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-qt/qtwebchannel/Manifest b/dev-qt/qtwebchannel/Manifest
index 3650e24f11e4..564980b259ba 100644
--- a/dev-qt/qtwebchannel/Manifest
+++ b/dev-qt/qtwebchannel/Manifest
@@ -1,3 +1,4 @@
DIST qtwebchannel-everywhere-src-5.11.0-rc.tar.xz 173728 BLAKE2B af68a062d1531641b170d7b4aa8d3946f35184519c6c5d80f8076b2c0c2509430ae540997bf120d2d20745881f776aaa55c91534bdf4363268c907f6bfb80202 SHA512 586c003116f70a62ef42a5c7ceb554485ad1ed421bc9c35017ba6cca32371fc4ee0fd4a5b7e067d10795e0eb8312384d28bfd46fcdcd4a1f8f80fd536d2cd029
+DIST qtwebchannel-everywhere-src-5.11.0-rc2.tar.xz 175232 BLAKE2B 7f6b296e70b942ce2394bffe9a7618448dafe78ddd3252ae8d6cad27d14b8814a30212e3499ee29960b576e95f31b6e0f727fb287b76c8586fa8d65c120c9774 SHA512 5aabe3263f5a8e22e6fef311d57264d6fa21bb20cc17bed19086f805d2dce34154e66bd8ace3a863140e23946b944da25edaa52555650a6dad12332d504c0850
DIST qtwebchannel-opensource-src-5.9.4.tar.xz 147456 BLAKE2B 703bb44c12bb856f311561c772ebe8b716dcbae9f75ac47d7b702f459d47a621431a5eb2cd15c44f60c8f178d6fb6d8405f1c79c5e5501a28ac566298959b58a SHA512 932b56c9e9944e0f639163c4e484ed5260bdc7a186e81a2a6cfa113d14892414cd5b81f2767132695fb2f251c91e4d5ec9711cba10983215baa6e8014689dfbb
DIST qtwebchannel-opensource-src-5.9.5.tar.xz 147564 BLAKE2B d66c190cae43875cf2845231c47ba5040db7b31724ea88333a8d818c111be9860c43fb7f0b3c16a3f139429361e6a1660ecfb1b2edb1a2e5a1c0f3e48797c4f6 SHA512 d5a3914c20fe541401a662e30f7277d9a57f9f4b9114832fa9b0425003542f646c295b63f31ae02c6cb69a45b88966f80f036f80b7df9a15fbc223a135d3944f
diff --git a/dev-qt/qtwebchannel/qtwebchannel-5.11.0_rc2.ebuild b/dev-qt/qtwebchannel/qtwebchannel-5.11.0_rc2.ebuild
new file mode 100644
index 000000000000..63c52e4c7747
--- /dev/null
+++ b/dev-qt/qtwebchannel/qtwebchannel-5.11.0_rc2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Qt5 module for integrating C++ and QML applications with HTML/JavaScript clients"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+IUSE="qml"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_mod qml quick src/src.pro
+ qt_use_disable_mod qml qml src/webchannel/webchannel.pro
+
+ qt5-build_src_prepare
+}