summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-12-15 01:43:20 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-12-15 15:17:35 -0500
commitbcc67fe645701a6ef44a1175de6b11e182d91094 (patch)
tree7f6c92aaf4423ff06bf9203a53a4cd6f1044574d /dev-qt
parentdev-qt/qttranslations: add 6.9.9999 (diff)
downloadgentoo-bcc67fe645701a6ef44a1175de6b11e182d91094.tar.gz
gentoo-bcc67fe645701a6ef44a1175de6b11e182d91094.tar.bz2
gentoo-bcc67fe645701a6ef44a1175de6b11e182d91094.zip
dev-qt/qtvirtualkeyboard: add 6.9.9999
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9.9999.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9.9999.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9.9999.ebuild
new file mode 100644
index 000000000000..43f6827a6965
--- /dev/null
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9.9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Customizable input framework and virtual keyboard for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+IUSE="+sound +spell"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtsvg-${PV}:6
+ sound? ( ~dev-qt/qtmultimedia-${PV}:6 )
+ spell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package sound Qt6Multimedia)
+ $(qt_feature spell hunspell)
+ -DINPUT_vkb_handwriting=no # neither cerence nor myscript are packaged
+ )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # rarely randomly(?) fails even with -j1
+ tst_layoutfilesystem
+ )
+
+ if use spell && has_version app-dicts/myspell-en; then
+ # 99% pass but minor sub-tests fail with myspell-en, needs looking into
+ ewarn "Warning: notable tests were skipped due to ${_} being installed"
+ CMAKE_SKIP_TESTS+=(
+ tst_inputpanel
+ tst_inputpanelcontrols2
+ )
+ else
+ einfo "tst_inputpanel can take >5mins, not known to actually hang"
+ fi
+
+ qt6-build_src_test
+}