summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-10-09 18:54:52 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-10-09 19:02:40 -0400
commite348405bae4e6094dc35832ecf58ff7c4c9d0485 (patch)
tree3a8b6ecfb945a8464ea9cd9590a2e540166e11e5 /dev-qt
parentdev-qt/qtbase: fix build with >=libxkbcommon-1.6.0 (diff)
downloadgentoo-e348405bae4e6094dc35832ecf58ff7c4c9d0485.tar.gz
gentoo-e348405bae4e6094dc35832ecf58ff7c4c9d0485.tar.bz2
gentoo-e348405bae4e6094dc35832ecf58ff7c4c9d0485.zip
dev-qt/qtgui: fix build with >=libxkbcommon-1.6.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtgui/files/qtgui-5.15.11-xkbcommon160.patch14
-rw-r--r--dev-qt/qtgui/qtgui-5.15.11.ebuild4
2 files changed, 18 insertions, 0 deletions
diff --git a/dev-qt/qtgui/files/qtgui-5.15.11-xkbcommon160.patch b/dev-qt/qtgui/files/qtgui-5.15.11-xkbcommon160.patch
new file mode 100644
index 000000000000..d0da76580df2
--- /dev/null
+++ b/dev-qt/qtgui/files/qtgui-5.15.11-xkbcommon160.patch
@@ -0,0 +1,14 @@
+These were removed in libxkbcommon-1.6.0[1] and were apparently
+unnecesary. Usage results in build failure.
+
+Just a quick fix while waiting for what [2] comes up with.
+
+[1] https://gitlab.freedesktop.org/xorg/proto/xorgproto/-/merge_requests/70
+[2] https://bugreports.qt.io/browse/QTBUG-117950
+--- a/src/platformsupport/input/xkbcommon/qxkbcommon.cpp
++++ b/src/platformsupport/input/xkbcommon/qxkbcommon.cpp
+@@ -276,4 +275,0 @@
+- Xkb2Qt<XKB_KEY_dead_lowline, Qt::Key_Dead_Lowline>,
+- Xkb2Qt<XKB_KEY_dead_aboveverticalline, Qt::Key_Dead_Aboveverticalline>,
+- Xkb2Qt<XKB_KEY_dead_belowverticalline, Qt::Key_Dead_Belowverticalline>,
+- Xkb2Qt<XKB_KEY_dead_longsolidusoverlay, Qt::Key_Dead_Longsolidusoverlay>,
diff --git a/dev-qt/qtgui/qtgui-5.15.11.ebuild b/dev-qt/qtgui/qtgui-5.15.11.ebuild
index cf55be1bdcd7..e8ef3f8a6ff9 100644
--- a/dev-qt/qtgui/qtgui-5.15.11.ebuild
+++ b/dev-qt/qtgui/qtgui-5.15.11.ebuild
@@ -127,6 +127,10 @@ QT5_GENTOO_PRIVATE_CONFIG=(
:gui
)
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.15.11-xkbcommon160.patch
+)
+
src_prepare() {
# don't add -O3 to CXXFLAGS, bug 549140
sed -i -e '/CONFIG\s*+=/s/optimize_full//' src/gui/gui.pro || die