summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 17:32:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:54 +0200
commitb3ef27b03812084aa905708b21faa851e3660ea2 (patch)
treeb54301ca37728baa7d82d8eb242dec9e9b49148c /dev-ros/amcl
parentdev-ros/rqt_action: bump eapi (diff)
downloadgentoo-b3ef27b03812084aa905708b21faa851e3660ea2.tar.gz
gentoo-b3ef27b03812084aa905708b21faa851e3660ea2.tar.bz2
gentoo-b3ef27b03812084aa905708b21faa851e3660ea2.zip
dev-ros/amcl: Bump to 1.17.0.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/amcl')
-rw-r--r--dev-ros/amcl/Manifest1
-rw-r--r--dev-ros/amcl/amcl-1.17.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/amcl/Manifest b/dev-ros/amcl/Manifest
index 70abd4ab2dde..da09cfb656de 100644
--- a/dev-ros/amcl/Manifest
+++ b/dev-ros/amcl/Manifest
@@ -1,2 +1,3 @@
DIST navigation-1.16.3.tar.gz 342459 BLAKE2B 736414787adee9c7511b0d90276395d33b9b52207d55ddd53836c9d77cb6809bf1946443878ad83e4461d0febf05b616b93ec0a18b34ed402323eb9bbb100861 SHA512 2eddb27fd3eff143674cc518be520e6df4d24a965689441f710105977f4bbe307736df5e6303319dde99362187091ea4f90eaec9da5a4bc678250410af174a71
DIST navigation-1.16.6.tar.gz 346529 BLAKE2B ed2d7ddd0ca9525f0ae22711d65fc2ede5f3046fd320e5016b93505616c4d476d65128695ff8830c4fa0b8dbdc276a1ec5951fdb4d0516f4d5f70897e4759f31 SHA512 c6bc3db39457c6bccba7ee2646504c4e1c91840a3297bdb9b92b28d93c608c0de113eb92527d4f499232de628d5b49816ec42522043500b20fb04056e2a7c97f
+DIST navigation-1.17.0.tar.gz 347660 BLAKE2B 8345dccf8ac5e24d1017631bb621ebaa472cc492d6361f29938501a149555771e03a6a46e16fdcc508bbe5c206ead80e9b79e9168b873685fca50a78ea7a7e13 SHA512 a536c8826bd88151ff8f51f83661282f8ccf1b19872bd91ed32987ef372797b94489380262e79ee2560ecb4d9e290c5b4f8d52c17721e2a41126eaea909bce26
diff --git a/dev-ros/amcl/amcl-1.17.0.ebuild b/dev-ros/amcl/amcl-1.17.0.ebuild
new file mode 100644
index 000000000000..130de3bbef70
--- /dev/null
+++ b/dev-ros/amcl/amcl-1.17.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Probabilistic localization system for a robot moving in 2D"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosbag
+ dev-libs/boost:=
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_ros
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/python_orocos_kdl[${PYTHON_USEDEP}] dev-ros/map_server[${PYTHON_USEDEP}] )
+"
+PATCHES=( "${FILESDIR}/cmake.patch" )