summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-23 13:24:57 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-23 17:18:45 +0200
commitf64cf94b5a7b01b999844a42b95db37c4ae8d896 (patch)
tree1bfe35746fd3e87ae1c25ef7d9579965fab42c15 /dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild
parentdev-ros/ament_cmake_target_dependencies: Remove old (diff)
downloadgentoo-f64cf94b5a7b01b999844a42b95db37c4ae8d896.tar.gz
gentoo-f64cf94b5a7b01b999844a42b95db37c4ae8d896.tar.bz2
gentoo-f64cf94b5a7b01b999844a42b95db37c4ae8d896.zip
dev-ros/ament_cmake_test: bump to 0.9.6
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild')
-rw-r--r--dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild b/dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild
index 938e0193c306..00d8aa0613ba 100644
--- a/dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild
+++ b/dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit cmake-utils python-r1
+inherit cmake python-r1
ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -42,18 +42,18 @@ BDEPEND="${DEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
src_configure() {
- python_foreach_impl cmake-utils_src_configure
+ python_foreach_impl cmake_src_configure
}
src_compile() {
- python_foreach_impl cmake-utils_src_compile
+ python_foreach_impl cmake_src_compile
}
src_test() {
- python_foreach_impl cmake-utils_src_test
+ python_foreach_impl cmake_src_test
}
src_install() {
- python_foreach_impl cmake-utils_src_install
+ python_foreach_impl cmake_src_install
python_foreach_impl python_optimize
}