summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-04 20:36:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-04 20:46:32 +0200
commitb38ceee7bca152a2adbcbd52f0c84779054467ae (patch)
tree498625f6bd9e3fb0dd6d6b1e36f4a04ad0e7b3a4 /dev-ros/carrot_planner/carrot_planner-1.16.2.ebuild
parentdev-ros/base_local_planner: Bump to 1.16.2. (diff)
downloadgentoo-b38ceee7bca152a2adbcbd52f0c84779054467ae.tar.gz
gentoo-b38ceee7bca152a2adbcbd52f0c84779054467ae.tar.bz2
gentoo-b38ceee7bca152a2adbcbd52f0c84779054467ae.zip
dev-ros/carrot_planner: Bump to 1.16.2.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros/carrot_planner/carrot_planner-1.16.2.ebuild')
-rw-r--r--dev-ros/carrot_planner/carrot_planner-1.16.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/carrot_planner/carrot_planner-1.16.2.ebuild b/dev-ros/carrot_planner/carrot_planner-1.16.2.ebuild
new file mode 100644
index 000000000000..86e76aa7b195
--- /dev/null
+++ b/dev-ros/carrot_planner/carrot_planner-1.16.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to find a legal place to put a carrot for the robot to follow"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/base_local_planner
+ dev-ros/costmap_2d
+ dev-cpp/eigen:3
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2
+ dev-ros/tf2_ros
+
+ dev-libs/boost:=
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"