summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-12 20:31:24 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-12 21:08:35 +0200
commitc9a78ac46a2679f141e56267484a038a8007485e (patch)
treedd867b82f3c6cfcc52ba9ed2343464feaf6d400c /dev-ros/dwa_local_planner/dwa_local_planner-1.17.1.ebuild
parentdev-ros/costmap_2d: Bump to 1.17.1. (diff)
downloadgentoo-c9a78ac46a2679f141e56267484a038a8007485e.tar.gz
gentoo-c9a78ac46a2679f141e56267484a038a8007485e.tar.bz2
gentoo-c9a78ac46a2679f141e56267484a038a8007485e.zip
dev-ros/dwa_local_planner: Bump to 1.17.1.
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/dwa_local_planner/dwa_local_planner-1.17.1.ebuild')
-rw-r--r--dev-ros/dwa_local_planner/dwa_local_planner-1.17.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/dwa_local_planner/dwa_local_planner-1.17.1.ebuild b/dev-ros/dwa_local_planner/dwa_local_planner-1.17.1.ebuild
new file mode 100644
index 000000000000..ae5574a54a45
--- /dev/null
+++ b/dev-ros/dwa_local_planner/dwa_local_planner-1.17.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Dynamic Window Approach to local robot navigation on a plane"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/angles
+ dev-ros/base_local_planner
+ dev-ros/costmap_2d
+ dev-ros/dynamic_reconfigure[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/eigen:3
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/roscpp
+
+ dev-ros/tf2
+ dev-ros/tf2_ros
+
+ dev-libs/boost:=[threads]
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"