summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-28 19:07:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-28 19:23:49 +0200
commit6622eed03eacb53ed88fcdf7948b70f30f7c0c06 (patch)
tree6ce6efc8384d175a47117b5e12d2d6e5dc9b9d14 /dev-ros/gmapping/gmapping-1.4.0.ebuild
parentros-meta/slam_gmapping: update license (diff)
downloadgentoo-6622eed03eacb53ed88fcdf7948b70f30f7c0c06.tar.gz
gentoo-6622eed03eacb53ed88fcdf7948b70f30f7c0c06.tar.bz2
gentoo-6622eed03eacb53ed88fcdf7948b70f30f7c0c06.zip
dev-ros/gmapping: Bump to 1.4.0.
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/gmapping/gmapping-1.4.0.ebuild')
-rw-r--r--dev-ros/gmapping/gmapping-1.4.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/gmapping/gmapping-1.4.0.ebuild b/dev-ros/gmapping/gmapping-1.4.0.ebuild
new file mode 100644
index 000000000000..307f03f929b1
--- /dev/null
+++ b/dev-ros/gmapping/gmapping-1.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/slam_gmapping"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for OpenSlam's Gmapping"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/openslam_gmapping
+ dev-ros/rosbag_storage
+ dev-ros/gmapping
+"
+DEPEND="${RDEPEND}
+ dev-ros/rostest"