summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 17:06:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 18:30:48 +0200
commit67f0496134b5dfee5973c77327d92adf6564703a (patch)
tree8cfc4a80d28f77fd5da528cb18a3221e128c88c1 /dev-ros/mavros_extras/mavros_extras-1.2.0.ebuild
parentdev-ros/mavros: Bump to 1.2.0. (diff)
downloadgentoo-67f0496134b5dfee5973c77327d92adf6564703a.tar.gz
gentoo-67f0496134b5dfee5973c77327d92adf6564703a.tar.bz2
gentoo-67f0496134b5dfee5973c77327d92adf6564703a.zip
dev-ros/mavros_extras: Bump to 1.2.0.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/mavros_extras/mavros_extras-1.2.0.ebuild')
-rw-r--r--dev-ros/mavros_extras/mavros_extras-1.2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/mavros_extras/mavros_extras-1.2.0.ebuild b/dev-ros/mavros_extras/mavros_extras-1.2.0.ebuild
new file mode 100644
index 000000000000..e7290bdf87be
--- /dev/null
+++ b/dev-ros/mavros_extras/mavros_extras-1.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extra nodes and plugins for mavros"
+LICENSE="GPL-3 LGPL-3 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/image_transport
+ dev-ros/cv_bridge
+ dev-ros/mavros
+ dev-ros/roscpp
+ dev-ros/mavros_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/urdf
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3
+ dev-ros/mavros_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"