summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-24 13:21:41 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-24 13:29:49 +0300
commitbe05dea52e8dd5dd90bc1a600bcc904e99e83777 (patch)
treef50be64a55e7e48b454d51141fe08c154f508e39 /dev-ros/python_cmake_module
parentdev-ros/console_bridge_vendor: enable py3.9, enable py3.10 (diff)
downloadgentoo-be05dea52e8dd5dd90bc1a600bcc904e99e83777.tar.gz
gentoo-be05dea52e8dd5dd90bc1a600bcc904e99e83777.tar.bz2
gentoo-be05dea52e8dd5dd90bc1a600bcc904e99e83777.zip
dev-ros/python_cmake_module: enable py3.9, enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-ros/python_cmake_module')
-rw-r--r--dev-ros/python_cmake_module/python_cmake_module-0.8.1.ebuild13
-rw-r--r--dev-ros/python_cmake_module/python_cmake_module-9999.ebuild13
2 files changed, 4 insertions, 22 deletions
diff --git a/dev-ros/python_cmake_module/python_cmake_module-0.8.1.ebuild b/dev-ros/python_cmake_module/python_cmake_module-0.8.1.ebuild
index 150095c180f0..a94a808de7ac 100644
--- a/dev-ros/python_cmake_module/python_cmake_module-0.8.1.ebuild
+++ b/dev-ros/python_cmake_module/python_cmake_module-0.8.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-any-r1
@@ -11,11 +11,10 @@ ROS_PN="python_cmake_module"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ros2/python_cmake_module"
- SRC_URI=""
- S=${WORKDIR}/${P}
else
SRC_URI="https://github.com/ros2/python_cmake_module/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="CMake module with extra functionality for Python"
@@ -23,17 +22,9 @@ HOMEPAGE="https://github.com/ros2/python_cmake_module"
LICENSE="Apache-2.0"
SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="
-"
-DEPEND="${RDEPEND}"
BDEPEND="
$(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
test? (
diff --git a/dev-ros/python_cmake_module/python_cmake_module-9999.ebuild b/dev-ros/python_cmake_module/python_cmake_module-9999.ebuild
index 150095c180f0..a94a808de7ac 100644
--- a/dev-ros/python_cmake_module/python_cmake_module-9999.ebuild
+++ b/dev-ros/python_cmake_module/python_cmake_module-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-any-r1
@@ -11,11 +11,10 @@ ROS_PN="python_cmake_module"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ros2/python_cmake_module"
- SRC_URI=""
- S=${WORKDIR}/${P}
else
SRC_URI="https://github.com/ros2/python_cmake_module/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="CMake module with extra functionality for Python"
@@ -23,17 +22,9 @@ HOMEPAGE="https://github.com/ros2/python_cmake_module"
LICENSE="Apache-2.0"
SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="
-"
-DEPEND="${RDEPEND}"
BDEPEND="
$(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
test? (