summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-10-14 13:35:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-10-14 13:35:22 +0200
commite0b61a6ade7ca1b32cdfd57bbded219659e59fb4 (patch)
treeff643373bc83b840a93a4e6e5d564fb9a4027522 /dev-ros/rospack/rospack-2.4.3.ebuild
parentdev-ros/openni2_launch: bump to 0.2.3 (diff)
downloadgentoo-e0b61a6ade7ca1b32cdfd57bbded219659e59fb4.tar.gz
gentoo-e0b61a6ade7ca1b32cdfd57bbded219659e59fb4.tar.bz2
gentoo-e0b61a6ade7ca1b32cdfd57bbded219659e59fb4.zip
dev-ros/rospack: bump to 2.4.3
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-ros/rospack/rospack-2.4.3.ebuild')
-rw-r--r--dev-ros/rospack/rospack-2.4.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/rospack/rospack-2.4.3.ebuild b/dev-ros/rospack/rospack-2.4.3.ebuild
new file mode 100644
index 000000000000..18b9f633ad3f
--- /dev/null
+++ b/dev-ros/rospack/rospack-2.4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rospack"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Retrieves information about ROS packages available on the filesystem"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/tinyxml2:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ >=dev-ros/cmake_modules-0.4.1
+ test? (
+ dev-cpp/gtest
+ dev-python/nose
+ )"
+
+PATCHES=(
+ "${FILESDIR}/gentoo.patch"
+)