summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-19 14:12:09 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-19 14:55:30 +0100
commit1f52e8642162adb391af507f4f2360b8447ab878 (patch)
tree07dc819e63959b522124ce00d90fa468aaf2d50b /dev-ros/rostime/rostime-0.6.0.ebuild
parentdev-ros/cpp_common: Bump to 0.6.0. (diff)
downloadgentoo-1f52e8642162adb391af507f4f2360b8447ab878.tar.gz
gentoo-1f52e8642162adb391af507f4f2360b8447ab878.tar.bz2
gentoo-1f52e8642162adb391af507f4f2360b8447ab878.zip
dev-ros/rostime: Bump to 0.6.0.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rostime/rostime-0.6.0.ebuild')
-rw-r--r--dev-ros/rostime/rostime-0.6.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rostime/rostime-0.6.0.ebuild b/dev-ros/rostime/rostime-0.6.0.ebuild
new file mode 100644
index 000000000000..e673fcc54390
--- /dev/null
+++ b/dev-ros/rostime/rostime-0.6.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Time and Duration implementations for C++ libraries"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/cpp_common
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"