summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-05 13:40:55 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-06 20:23:20 +0100
commit6831451d290765365ed0df96562d8998ff065da0 (patch)
tree0f76036ea3798e44bda4ba95d64927e85e2e7394 /dev-ros/rosunit/rosunit-1.14.3.ebuild
parentdev-ros/rosmake: Bump to 1.14.3. (diff)
downloadgentoo-6831451d290765365ed0df96562d8998ff065da0.tar.gz
gentoo-6831451d290765365ed0df96562d8998ff065da0.tar.bz2
gentoo-6831451d290765365ed0df96562d8998ff065da0.zip
dev-ros/rosunit: Bump to 1.14.3.
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'dev-ros/rosunit/rosunit-1.14.3.ebuild')
-rw-r--r--dev-ros/rosunit/rosunit-1.14.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosunit/rosunit-1.14.3.ebuild b/dev-ros/rosunit/rosunit-1.14.3.ebuild
new file mode 100644
index 000000000000..eb257dfeac25
--- /dev/null
+++ b/dev-ros/rosunit/rosunit-1.14.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Unit-testing package for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"