summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-15 08:07:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-15 08:25:27 +0200
commit5c06b76da032b5c78de8f3a3d99017c7707d1c72 (patch)
tree3b659a57896acce3e14e574d3b231ff5f97d408f /dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild
parentdev-python/rospkg: bump to 1.1.2 (diff)
downloadgentoo-5c06b76da032b5c78de8f3a3d99017c7707d1c72.tar.gz
gentoo-5c06b76da032b5c78de8f3a3d99017c7707d1c72.tar.bz2
gentoo-5c06b76da032b5c78de8f3a3d99017c7707d1c72.zip
dev-ros/rqt_graph: bump to 0.4.9
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild')
-rw-r--r--dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild b/dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild
new file mode 100644
index 000000000000..1f2bff4c39fc
--- /dev/null
+++ b/dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_graph"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosservice[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"