summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-06 14:15:37 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-06 14:32:51 +0200
commit520e7865718ca32ca714d0bce499e8ca21bfa4c4 (patch)
tree349a1845024177f52d8d1cb4e2594241a1682d2a /dev-ros/rqt_py_console/rqt_py_console-0.4.10.ebuild
parentdev-ros/rqt_runtime_monitor: bump to 0.5.9 (diff)
downloadgentoo-520e7865718ca32ca714d0bce499e8ca21bfa4c4.tar.gz
gentoo-520e7865718ca32ca714d0bce499e8ca21bfa4c4.tar.bz2
gentoo-520e7865718ca32ca714d0bce499e8ca21bfa4c4.zip
dev-ros/rqt_py_console: bump to 0.4.10
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_py_console/rqt_py_console-0.4.10.ebuild')
-rw-r--r--dev-ros/rqt_py_console/rqt_py_console-0.4.10.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rqt_py_console/rqt_py_console-0.4.10.ebuild b/dev-ros/rqt_py_console/rqt_py_console-0.4.10.ebuild
new file mode 100644
index 000000000000..474d032774d8
--- /dev/null
+++ b/dev-ros/rqt_py_console/rqt_py_console-0.4.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_py_console"
+
+inherit ros-catkin
+
+DESCRIPTION="Python GUI plugin providing an interactive Python console"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/qt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"