summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-28 08:36:59 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-28 12:26:45 +0100
commit5e9f552cb2a34e797309b8abef54367ea0d69b89 (patch)
tree71ae4e0814047b376ecb30c5ea4c0ad7ebe1ffa0 /dev-ros/rqt_shell/rqt_shell-0.4.6.ebuild
parentdev-ros/rqt_service_caller: Bump to 0.4.6. (diff)
downloadgentoo-5e9f552cb2a34e797309b8abef54367ea0d69b89.tar.gz
gentoo-5e9f552cb2a34e797309b8abef54367ea0d69b89.tar.bz2
gentoo-5e9f552cb2a34e797309b8abef54367ea0d69b89.zip
dev-ros/rqt_shell: Bump to 0.4.6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rqt_shell/rqt_shell-0.4.6.ebuild')
-rw-r--r--dev-ros/rqt_shell/rqt_shell-0.4.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rqt_shell/rqt_shell-0.4.6.ebuild b/dev-ros/rqt_shell/rqt_shell-0.4.6.ebuild
new file mode 100644
index 000000000000..a6cbadc6a46e
--- /dev/null
+++ b/dev-ros/rqt_shell/rqt_shell-0.4.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin providing an interactive shell"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"