summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 12:31:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:21:01 +0200
commit902e578dc6d93d3aa808a1d64045550d29954e4c (patch)
tree73ac8283a68e2850209b83a564b2511b66dd1a84 /dev-ros/test_rospy/test_rospy-1.15.8.ebuild
parentdev-ros/test_rosparam: Bump to 1.15.8. (diff)
downloadgentoo-902e578dc6d93d3aa808a1d64045550d29954e4c.tar.gz
gentoo-902e578dc6d93d3aa808a1d64045550d29954e4c.tar.bz2
gentoo-902e578dc6d93d3aa808a1d64045550d29954e4c.zip
dev-ros/test_rospy: Bump to 1.15.8.
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rospy/test_rospy-1.15.8.ebuild')
-rw-r--r--dev-ros/test_rospy/test_rospy-1.15.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/test_rospy-1.15.8.ebuild b/dev-ros/test_rospy/test_rospy-1.15.8.ebuild
new file mode 100644
index 000000000000..7d398e80068c
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.15.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_SINGLE_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
+ test? (
+ $(python_gen_cond_dep "dev-python/numpy[\${PYTHON_USEDEP}]")
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"