summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-09 11:02:02 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-09 12:39:11 +0100
commit164773493a678520f21d4fe057282a722ae0942c (patch)
treed015c6e416c1f282da7c0f8bc159ae7133cfee9c /dev-ros/test_rosservice/test_rosservice-1.13.6.ebuild
parentdev-ros/test_rospy: Bump to 1.13.6. (diff)
downloadgentoo-164773493a678520f21d4fe057282a722ae0942c.tar.gz
gentoo-164773493a678520f21d4fe057282a722ae0942c.tar.bz2
gentoo-164773493a678520f21d4fe057282a722ae0942c.zip
dev-ros/test_rosservice: Bump to 1.13.6.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ros/test_rosservice/test_rosservice-1.13.6.ebuild')
-rw-r--r--dev-ros/test_rosservice/test_rosservice-1.13.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/test_rosservice/test_rosservice-1.13.6.ebuild b/dev-ros/test_rosservice/test_rosservice-1.13.6.ebuild
new file mode 100644
index 000000000000..e129fbdc99eb
--- /dev/null
+++ b/dev-ros/test_rosservice/test_rosservice-1.13.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"