summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-12 18:47:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-12 18:58:18 +0200
commit385374bba2d5659b544423aa7dca75da134af01c (patch)
treec9b1850675a465bcd7e6611d7c645885548da3c7 /dev-ros/tf/tf-1.13.2-r4.ebuild
parentdev-ros/rviz: add slot dep on agles (diff)
downloadgentoo-385374bba2d5659b544423aa7dca75da134af01c.tar.gz
gentoo-385374bba2d5659b544423aa7dca75da134af01c.tar.bz2
gentoo-385374bba2d5659b544423aa7dca75da134af01c.zip
dev-ros/tf: add slot dep on angles
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/tf/tf-1.13.2-r4.ebuild')
-rw-r--r--dev-ros/tf/tf-1.13.2-r4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ros/tf/tf-1.13.2-r4.ebuild b/dev-ros/tf/tf-1.13.2-r4.ebuild
new file mode 100644
index 000000000000..550fa9b2c71b
--- /dev/null
+++ b/dev-ros/tf/tf-1.13.2-r4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/geometry"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Maintains the relationship between frames in a tree structure over time"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads(+)]
+ dev-ros/angles:0
+ dev-ros/message_filters
+ dev-ros/rosconsole
+ dev-ros/rostime
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/numpy[\${PYTHON_USEDEP}]")
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"
+PATCHES=( "${FILESDIR}/yaml.patch" )