summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-04-07 15:48:17 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-04-07 16:08:16 +0200
commit8f3afceb489054f9f5bb77ad7bb657bae37d30b5 (patch)
tree27b41e4c5859162b12c80bf8d07e2109a152ced0 /dev-ros/urdf
parentsci-libs/orocos_kdl: addsubslot (diff)
downloadgentoo-8f3afceb489054f9f5bb77ad7bb657bae37d30b5.tar.gz
gentoo-8f3afceb489054f9f5bb77ad7bb657bae37d30b5.tar.bz2
gentoo-8f3afceb489054f9f5bb77ad7bb657bae37d30b5.zip
dev-ros/urdf: bump to 1.13.1
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-ros/urdf')
-rw-r--r--dev-ros/urdf/Manifest1
-rw-r--r--dev-ros/urdf/metadata.xml2
-rw-r--r--dev-ros/urdf/urdf-1.13.1.ebuild30
-rw-r--r--dev-ros/urdf/urdf-9999.ebuild7
4 files changed, 35 insertions, 5 deletions
diff --git a/dev-ros/urdf/Manifest b/dev-ros/urdf/Manifest
index 86b1a63004bc..502fcb8fc973 100644
--- a/dev-ros/urdf/Manifest
+++ b/dev-ros/urdf/Manifest
@@ -1 +1,2 @@
DIST robot_model-1.12.11.tar.gz 277822 BLAKE2B 3bdd2b931ddfd062594ccb2be4ce6d4863a5fa66f538c3ee48c3600b3be249d267f9d03aa9a701bc6ab22c4297d659a24da668fedcd25c75fe128c43cc781be0 SHA512 8dea6fc72e9beaddbf9a82cb177561cb89c69ef8f58f0c4882598f6cc33a0e10564d9696f07b6f4e3e3404d3f1f5236e54eea4b8d249be0a216cd3ce12a03cde
+DIST urdf-1.13.1.tar.gz 43326 BLAKE2B dce42216cc21595b91964b970d45bbc79d8c144ee331f72e9c3d31f024f3c0f18e59563055df7c4e4337f5bf1361a838a07c80dabb100b7522999a0949384639 SHA512 8a27b0bff40cb42d5eeb62422c371a48c25e3f4513711b86752192b618ceec308bcebb1d52aa3d058448d30c6724cc2cc337f815b9043874793e82e6404d6648
diff --git a/dev-ros/urdf/metadata.xml b/dev-ros/urdf/metadata.xml
index ceef7c794c18..05f17b2ac35d 100644
--- a/dev-ros/urdf/metadata.xml
+++ b/dev-ros/urdf/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
- <remote-id type="github">ros/robot_model</remote-id>
+ <remote-id type="github">ros/urdf</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ros/urdf/urdf-1.13.1.ebuild b/dev-ros/urdf/urdf-1.13.1.ebuild
new file mode 100644
index 000000000000..ab97666057c9
--- /dev/null
+++ b/dev-ros/urdf/urdf-1.13.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/urdf"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="C++ parser for the Unified Robot Description Format (URDF)"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-libs/urdfdom
+ dev-libs/urdfdom_headers
+ dev-ros/urdf_parser_plugin
+ dev-ros/pluginlib
+ dev-ros/rosconsole_bridge
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-libs/tinyxml
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-cpp/gtest )"
diff --git a/dev-ros/urdf/urdf-9999.ebuild b/dev-ros/urdf/urdf-9999.ebuild
index eaa16e63dedc..ab97666057c9 100644
--- a/dev-ros/urdf/urdf-9999.ebuild
+++ b/dev-ros/urdf/urdf-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-ROS_REPO_URI="https://github.com/ros/robot_model"
+ROS_REPO_URI="https://github.com/ros/urdf"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
PYTHON_COMPAT=( python2_7 )
@@ -20,12 +20,11 @@ RDEPEND="
dev-libs/urdfdom_headers
dev-ros/urdf_parser_plugin
dev-ros/pluginlib
- dev-libs/tinyxml2:=
dev-ros/rosconsole_bridge
dev-libs/console_bridge:=
dev-ros/roscpp
dev-libs/tinyxml
+ dev-libs/tinyxml2:=
"
DEPEND="${RDEPEND}
- dev-ros/cmake_modules
test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-cpp/gtest )"