summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 14:43:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:20 +0200
commitd16b9dd27d00b7052f74a94fd493c47311fb53ea (patch)
treea00e68c89671a623146dbc70906ef2a827e02a97 /dev-ros/xmlrpcpp/xmlrpcpp-9999.ebuild
parentdev-lang/go: sync live ebuild (diff)
downloadgentoo-d16b9dd27d00b7052f74a94fd493c47311fb53ea.tar.gz
gentoo-d16b9dd27d00b7052f74a94fd493c47311fb53ea.tar.bz2
gentoo-d16b9dd27d00b7052f74a94fd493c47311fb53ea.zip
dev-ros/xmlrpcpp: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/xmlrpcpp/xmlrpcpp-9999.ebuild')
-rw-r--r--dev-ros/xmlrpcpp/xmlrpcpp-9999.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ros/xmlrpcpp/xmlrpcpp-9999.ebuild b/dev-ros/xmlrpcpp/xmlrpcpp-9999.ebuild
new file mode 100644
index 000000000000..a0ae0fd21c51
--- /dev/null
+++ b/dev-ros/xmlrpcpp/xmlrpcpp-9999.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of the XML-RPC protocol"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/cpp_common"
+DEPEND="${RDEPEND}"