summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-24 10:49:17 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-24 10:49:17 +0200
commita2f83eb52bd631c748ed8bdbdb341d82217fa953 (patch)
tree7a0077341ba05f2ab42abe2411286adf5cb25b81 /dev-ros
parentdev-ros/uuid_msgs: Initial import. Ebuild by me. (diff)
downloadgentoo-a2f83eb52bd631c748ed8bdbdb341d82217fa953.tar.gz
gentoo-a2f83eb52bd631c748ed8bdbdb341d82217fa953.tar.bz2
gentoo-a2f83eb52bd631c748ed8bdbdb341d82217fa953.zip
dev-ros/unique_id: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/unique_id/Manifest1
-rw-r--r--dev-ros/unique_id/metadata.xml5
-rw-r--r--dev-ros/unique_id/unique_id-1.0.5.ebuild25
-rw-r--r--dev-ros/unique_id/unique_id-9999.ebuild25
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ros/unique_id/Manifest b/dev-ros/unique_id/Manifest
new file mode 100644
index 000000000000..3f304f48095a
--- /dev/null
+++ b/dev-ros/unique_id/Manifest
@@ -0,0 +1 @@
+DIST unique_identifier-1.0.5.tar.gz 12252 SHA256 70f3fc1e8b81ce2a80383fe1bec69dd0760913852a78ff1d010e6a1c2baa1d3c SHA512 0a12fe42346d83813eed78a369afeec171df928abad2cfa804cb314907fa43a3edad3cef5efe51b3223f819a80ac1633f069e7e0bd721efc9f487a1089d160d3 WHIRLPOOL 2b18cb09845254b88026ef69739203a66438563094375e5cd711239af90f157f1727deb82252c719fd5b78a372c8877771c42bbd30c360acc8c943676a343197
diff --git a/dev-ros/unique_id/metadata.xml b/dev-ros/unique_id/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/unique_id/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/unique_id/unique_id-1.0.5.ebuild b/dev-ros/unique_id/unique_id-1.0.5.ebuild
new file mode 100644
index 000000000000..41ebb733434a
--- /dev/null
+++ b/dev-ros/unique_id/unique_id-1.0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
+VER_PREFIX=unique_identifier-
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Python and C++ interfaces for universally unique identifiers"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/unique_id/unique_id-9999.ebuild b/dev-ros/unique_id/unique_id-9999.ebuild
new file mode 100644
index 000000000000..41ebb733434a
--- /dev/null
+++ b/dev-ros/unique_id/unique_id-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
+VER_PREFIX=unique_identifier-
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Python and C++ interfaces for universally unique identifiers"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"