summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-05-12 07:47:10 +0200
committerHans de Graaff <graaff@gentoo.org>2017-05-12 08:36:19 +0200
commit653a7fe647c66cdaa497acd32f7af4015a461db9 (patch)
tree7555a37c883151b49754377f8ee2ac5794f6bff1 /dev-ruby/actionpack-xml_parser/actionpack-xml_parser-2.0.1.ebuild
parentapp-admin/puppet-agent: cleanup (diff)
downloadgentoo-653a7fe647c66cdaa497acd32f7af4015a461db9.tar.gz
gentoo-653a7fe647c66cdaa497acd32f7af4015a461db9.tar.bz2
gentoo-653a7fe647c66cdaa497acd32f7af4015a461db9.zip
dev-ruby/actionpack-xml_parser: add 2.0.1
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/actionpack-xml_parser/actionpack-xml_parser-2.0.1.ebuild')
-rw-r--r--dev-ruby/actionpack-xml_parser/actionpack-xml_parser-2.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/actionpack-xml_parser/actionpack-xml_parser-2.0.1.ebuild b/dev-ruby/actionpack-xml_parser/actionpack-xml_parser-2.0.1.ebuild
new file mode 100644
index 000000000000..102baa46a2f7
--- /dev/null
+++ b/dev-ruby/actionpack-xml_parser/actionpack-xml_parser-2.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="XML parameters parser for Action Pack (removed from core in Rails 4.0)"
+HOMEPAGE="https://github.com/rails/actionpack-xml_parser"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="2"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/actionpack-5*:* =dev-ruby/railties-5*:*"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" Rakefile test/helper.rb || die
+ sed -i -e '1igem "actionpack", "~>5.0"' test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e "Dir['test/*_test.rb'].each{|f| require f}"
+}