summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-05 04:08:26 +0100
committerSam James <sam@gentoo.org>2023-04-05 04:16:14 +0100
commit4037dd03668239266420c55a063a4710386b39a4 (patch)
treeae1dbc7ef78af52563133694c7d7234714df416f /dev-ruby/actiontext
parentdev-ruby/actionmailbox: enable ruby31 for 6.1.x (diff)
downloadgentoo-4037dd03668239266420c55a063a4710386b39a4.tar.gz
gentoo-4037dd03668239266420c55a063a4710386b39a4.tar.bz2
gentoo-4037dd03668239266420c55a063a4710386b39a4.zip
dev-ruby/actiontext: enable ruby31 for 6.1.x
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/actiontext')
-rw-r--r--dev-ruby/actiontext/actiontext-6.1.7.3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/actiontext/actiontext-6.1.7.3.ebuild b/dev-ruby/actiontext/actiontext-6.1.7.3.ebuild
index 9e1a1218c361..d5ede02d3596 100644
--- a/dev-ruby/actiontext/actiontext-6.1.7.3.ebuild
+++ b/dev-ruby/actiontext/actiontext-6.1.7.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30"
+USE_RUBY="ruby27 ruby30 ruby31"
RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
@@ -41,7 +41,7 @@ ruby_add_bdepend "test? (
all_ruby_prepare() {
# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
- sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webpacker\|webrick\|webmock\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|bootsnap\|capybara\|dalli\|connection_pool\)/ s:^:#:" \
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webpacker\|webrick\|webmock\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|rack-test\|bootsnap\|capybara\|dalli\|connection_pool\)/ s:^:#:" \
-e '/:job/,/end/ s:^:#:' \
-e '/group :\(cable\|doc\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
-i ../Gemfile || die