summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-12-18 15:42:27 +0100
committerHans de Graaff <graaff@gentoo.org>2022-12-18 15:43:52 +0100
commit03a8a466518df38b8fb66778a9af903e5734d8fc (patch)
tree77dc1adecbfe4a1b7a3d311b7fdfec8323389aa0 /dev-ruby/asciidoctor
parentdev-ruby/asciimath: enable ruby31 and disable ruby26 (diff)
downloadgentoo-03a8a466518df38b8fb66778a9af903e5734d8fc.tar.gz
gentoo-03a8a466518df38b8fb66778a9af903e5734d8fc.tar.bz2
gentoo-03a8a466518df38b8fb66778a9af903e5734d8fc.zip
dev-ruby/asciidoctor: add 2.0.18
Also depend on erubi for tests instead of erubis. Closes: https://bugs.gentoo.org/886581 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/asciidoctor')
-rw-r--r--dev-ruby/asciidoctor/Manifest1
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-2.0.18.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor/Manifest b/dev-ruby/asciidoctor/Manifest
index f44d9d197471..59c8639d5218 100644
--- a/dev-ruby/asciidoctor/Manifest
+++ b/dev-ruby/asciidoctor/Manifest
@@ -1,2 +1,3 @@
DIST asciidoctor-2.0.15.tar.gz 1633310 BLAKE2B 58029acdf3832459dde5df2835749bb781ccbaa547fa4a09dc10a69fbef36ed690fac7cd0e2b3da1a5de847be678d0ad410c17c6768e466fffc7ad30b5d9d4bf SHA512 4cd0ce922d5db5bc5b31ebc75707c2e9e2a94a2a28eeb68ed25f55c46c416c950d28b880c4b1ab52bbcdda9ee4ee7b1c297049754d214983b68eedf2d96492d8
DIST asciidoctor-2.0.16.tar.gz 1651396 BLAKE2B 6da2971c38e48497b482ca1bc22916a10c3505d7bd4fa802ffd4939a0c0986d650a30b5870fea7979046c4b61c6e97aec08d9ba345ce350de6721d545c2923b5 SHA512 95003640632cc99f1edd2447156135267ad78f24983418817f19256fab6e313b8faab9f676317e7cc610728abb8b047f2d2f481f4700009a2d6bdd3b9efcc463
+DIST asciidoctor-2.0.18.tar.gz 1690964 BLAKE2B 5e14371c7201f83529fa28a63b031599ebf53fda62b4701942f134e7f1dae923a07676aafeac4c5e1fc3c25b6e9044b34b9b2e5b07491f1ca8e68076aa02301b SHA512 b47b377520046d95101fc9bcd3defdf7219714ebadc0d069cb108d39a349fcf1abd1e61178e1515f75bb69e9e3d0f8cb2de67de5a0f8aa75fdd139d693c0e437
diff --git a/dev-ruby/asciidoctor/asciidoctor-2.0.18.ebuild b/dev-ruby/asciidoctor/asciidoctor-2.0.18.ebuild
new file mode 100644
index 000000000000..2b122dc2ee85
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-2.0.18.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_TEST="CUCUMBER_PUBLISH_QUIET=true test features"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_GEMSPEC="asciidoctor.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/concurrent-ruby
+ dev-ruby/erubi
+ dev-ruby/haml
+ dev-ruby/nokogiri
+ dev-ruby/rouge
+ dev-ruby/slim
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+
+ sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid broken blocks_test.rb (already appears to be fixed upstream)
+ rm -f test/blocks_test.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}