summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-05-25 07:03:16 +0200
committerHans de Graaff <graaff@gentoo.org>2018-05-25 07:03:16 +0200
commit348c2f1662f7467d34000e27a33f0568e27c72b7 (patch)
treebae934b4b8e8e2e7b67e0dcd792bfb4aa432b870 /dev-ruby/connection_pool/connection_pool-2.2.2.ebuild
parentmedia-tv/xmltv: Dropped to ~ppc, bug 652902 (diff)
downloadgentoo-348c2f1662f7467d34000e27a33f0568e27c72b7.tar.gz
gentoo-348c2f1662f7467d34000e27a33f0568e27c72b7.tar.bz2
gentoo-348c2f1662f7467d34000e27a33f0568e27c72b7.zip
dev-ruby/connection_pool: add 2.2.2
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/connection_pool/connection_pool-2.2.2.ebuild')
-rw-r--r--dev-ruby/connection_pool/connection_pool-2.2.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/connection_pool/connection_pool-2.2.2.ebuild b/dev-ruby/connection_pool/connection_pool-2.2.2.ebuild
new file mode 100644
index 000000000000..97a8f019f2a1
--- /dev/null
+++ b/dev-ruby/connection_pool/connection_pool-2.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changes.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generic connection pooling for Ruby"
+HOMEPAGE="https://github.com/mperham/connection_pool"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' connection_pool.gemspec || die
+ sed -i -e '/bundler/d' Rakefile || die
+ sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 5.0'/" test/helper.rb || die
+}