summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-05-13 08:44:18 +0200
committerHans de Graaff <graaff@gentoo.org>2021-05-13 08:44:18 +0200
commitd9361b1475d60f4567db8e0f557d9778e5da8a4a (patch)
tree4aff0e2f975895bb391f3713a4b9b870ff808d4e /dev-ruby/date_validator/date_validator-0.11.0.ebuild
parentdev-ruby/bundler: add 2.2.17 (diff)
downloadgentoo-d9361b1475d60f4567db8e0f557d9778e5da8a4a.tar.gz
gentoo-d9361b1475d60f4567db8e0f557d9778e5da8a4a.tar.bz2
gentoo-d9361b1475d60f4567db8e0f557d9778e5da8a4a.zip
dev-ruby/date_validator: add 0.11.0
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/date_validator/date_validator-0.11.0.ebuild')
-rw-r--r--dev-ruby/date_validator/date_validator-0.11.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/date_validator/date_validator-0.11.0.ebuild b/dev-ruby/date_validator/date_validator-0.11.0.ebuild
new file mode 100644
index 000000000000..8d4f4549e483
--- /dev/null
+++ b/dev-ruby/date_validator/date_validator-0.11.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+# if ever needed
+#GITHUB_USER="codegram"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails"
+HOMEPAGE="https://github.com/codegram/date_validator"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activemodel-3.0:*
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest
+ >=dev-ruby/tzinfo-0.3
+ >=dev-ruby/activesupport-3.0
+ )
+ doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/git ls-files/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i \
+ -e '/[Bb]undler/s/^/#/' Rakefile || die
+ # Fix tests
+ sed -i -e "1irequire 'active_support'; require 'active_support/core_ext/time/zones'" test/test_helper.rb || die
+}