summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-01 07:09:07 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-01 07:09:07 +0200
commit10b5eb5ef454713519b6081fc38b675583d193ee (patch)
tree68c8e68df60b8a7f57a886cd9d1b7ff61f3389e1 /dev-ruby/ddplugin/ddplugin-1.0.2.ebuild
parentdev-lang/perl-5.24.3-r1: ppc64 stable, bug 648460 (diff)
downloadgentoo-10b5eb5ef454713519b6081fc38b675583d193ee.tar.gz
gentoo-10b5eb5ef454713519b6081fc38b675583d193ee.tar.bz2
gentoo-10b5eb5ef454713519b6081fc38b675583d193ee.zip
dev-ruby/ddplugin: add 1.0.2
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/ddplugin/ddplugin-1.0.2.ebuild')
-rw-r--r--dev-ruby/ddplugin/ddplugin-1.0.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/ddplugin/ddplugin-1.0.2.ebuild b/dev-ruby/ddplugin/ddplugin-1.0.2.ebuild
new file mode 100644
index 000000000000..f5030d83d56e
--- /dev/null
+++ b/dev-ruby/ddplugin/ddplugin-1.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides plugin management for Ruby projects"
+HOMEPAGE="https://github.com/ddfreyne/ddplugin/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/coverall/I s:^:#:' test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}