summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-02-01 08:00:56 +0100
committerHans de Graaff <graaff@gentoo.org>2024-02-01 08:05:48 +0100
commit98b326caa7d8ddcbf6d306a4c1ca7e26d0627784 (patch)
tree5da81c1d4b22efbbcfb7f89c78193ceb2fa7a0c7 /dev-ruby/diff-lcs
parentdev-python/sybil: Bump to 6.0.3 (diff)
downloadgentoo-98b326caa7d8ddcbf6d306a4c1ca7e26d0627784.tar.gz
gentoo-98b326caa7d8ddcbf6d306a4c1ca7e26d0627784.tar.bz2
gentoo-98b326caa7d8ddcbf6d306a4c1ca7e26d0627784.zip
dev-ruby/diff-lcs: add 1.5.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/diff-lcs')
-rw-r--r--dev-ruby/diff-lcs/Manifest1
-rw-r--r--dev-ruby/diff-lcs/diff-lcs-1.5.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/diff-lcs/Manifest b/dev-ruby/diff-lcs/Manifest
index 5c69600af348..82610ea80a0c 100644
--- a/dev-ruby/diff-lcs/Manifest
+++ b/dev-ruby/diff-lcs/Manifest
@@ -1 +1,2 @@
DIST diff-lcs-1.5.0.gem 52736 BLAKE2B ff405fd3ed5238af3eba2ab4fa277edca0eec66df93b0e8d6fba1a52980d484623e57f70587de31fec1696e556f2ae90d82af4b856a9bd4a248de12aa74ada4a SHA512 5cef9dc1d143217cc402173e2b84ffdcbb8d5a4d05716bdbca732ac00d73591e4cab2f7e792382a3686d8e72fdc32269fd7100941d602ca6d683e7645229ef8d
+DIST diff-lcs-1.5.1.gem 53248 BLAKE2B a40399223c659b548e59605eb537faae8eff139cacf793fea6af1e543016f8afa80049490dccf915edb0063bd3d71705e47c6343e1f616903b8c12a6f37c8cf4 SHA512 ad0357a047b57bb0314b158f92e83485cec9fe6a3dfeb16117d57cf746ee38545f652397093448862ff36d13945bda3b26bb22b5d0d91643b16ae11548ef463b
diff --git a/dev-ruby/diff-lcs/diff-lcs-1.5.1.ebuild b/dev-ruby/diff-lcs/diff-lcs-1.5.1.ebuild
new file mode 100644
index 000000000000..6c8b61e3ef2f
--- /dev/null
+++ b/dev-ruby/diff-lcs/diff-lcs-1.5.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Use the McIlroy-Hunt LCS algorithm to compute differences"
+HOMEPAGE="https://github.com/halostatue/diff-lcs"
+
+LICENSE="|| ( Artistic MIT GPL-2+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+each_ruby_prepare() {
+ # Use the current ruby to test script invocation
+ sed -e "/system/ s:ruby:${RUBY}:" \
+ -i spec/ldiff_spec.rb || die
+}