summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-10-01 08:04:47 +0200
committerHans de Graaff <graaff@gentoo.org>2016-10-01 08:04:47 +0200
commit1d8e207798d143425eea20e972f1dc812023ab27 (patch)
treee6d22e54474539a760a8b18b192635f7ad0ff010 /dev-ruby/http-cookie/http-cookie-1.0.3.ebuild
parentsys-apps/openrc: 0.22.1 version bump (diff)
downloadgentoo-1d8e207798d143425eea20e972f1dc812023ab27.tar.gz
gentoo-1d8e207798d143425eea20e972f1dc812023ab27.tar.bz2
gentoo-1d8e207798d143425eea20e972f1dc812023ab27.zip
dev-ruby/http-cookie: add 1.0.3
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/http-cookie/http-cookie-1.0.3.ebuild')
-rw-r--r--dev-ruby/http-cookie/http-cookie-1.0.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/http-cookie/http-cookie-1.0.3.ebuild b/dev-ruby/http-cookie/http-cookie-1.0.3.ebuild
new file mode 100644
index 000000000000..e51aaf8cb142
--- /dev/null
+++ b/dev-ruby/http-cookie/http-cookie-1.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library to handle HTTP cookies"
+HOMEPAGE="https://github.com/sparklemotion/http-cookie"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/domain_name-0.5:0"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/d" -e "/bundler/d" Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_http_cookie.rb || die
+ ${RUBY} -Ilib test/test_http_cookie_jar.rb || die
+}