summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-05 03:05:30 +0100
committerSam James <sam@gentoo.org>2023-04-05 04:16:07 +0100
commit09f1485536783ef9d2f7309ca29b899133162c43 (patch)
tree902b4e41d5953c1017a27358b139d1b216dc3f3e /dev-ruby/mail/mail-2.7.1-r2.ebuild
parentdev-ruby/ruby-net-ldap: add 0.18.0 (diff)
downloadgentoo-09f1485536783ef9d2f7309ca29b899133162c43.tar.gz
gentoo-09f1485536783ef9d2f7309ca29b899133162c43.tar.bz2
gentoo-09f1485536783ef9d2f7309ca29b899133162c43.zip
dev-ruby/mail: fix 2.7.x compat w/ newer psych (+ enable ruby31, enable ruby32)
mail-2.7.x is still needed for Rails. It turns out that this got broken by newer Psych so tests were failing for ruby27 too. Backport the upstream patch (actually, use Debian's backport, done for us) which is pretty conversative and just adds a shim for newer Psych to set the needed attributes. Closes: https://bugs.gentoo.org/835322 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/mail/mail-2.7.1-r2.ebuild')
-rw-r--r--dev-ruby/mail/mail-2.7.1-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/mail/mail-2.7.1-r2.ebuild b/dev-ruby/mail/mail-2.7.1-r2.ebuild
new file mode 100644
index 000000000000..aa87cad31b49
--- /dev/null
+++ b/dev-ruby/mail/mail-2.7.1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md"
+
+RUBY_FAKEGEM_GEMSPEC="mail.gemspec"
+
+inherit ruby-fakegem
+
+GITHUB_USER="mikel"
+
+DESCRIPTION="An email handling library"
+HOMEPAGE="https://github.com/mikel/mail"
+SRC_URI="https://github.com/${GITHUB_USER}/mail/archive/${PV}.tar.gz -> ${P}-git.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/mini_mime-0.1.1"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-psych-4.patch
+)
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undle/d' -e '6d' Rakefile || die "Unable to remove Bundler code."
+}