summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-06-18 06:19:22 +0200
committerHans de Graaff <graaff@gentoo.org>2023-06-18 06:22:06 +0200
commite2194a6b13efcded9f354df3a8b4d2a4d13c8ff9 (patch)
treecdcec19186318ea36ac5f7e789813ccdbfe37b04 /dev-ruby/pkg-config
parentdev-ruby/gruff: add 0.22.0 (diff)
downloadgentoo-e2194a6b13efcded9f354df3a8b4d2a4d13c8ff9.tar.gz
gentoo-e2194a6b13efcded9f354df3a8b4d2a4d13c8ff9.tar.bz2
gentoo-e2194a6b13efcded9f354df3a8b4d2a4d13c8ff9.zip
dev-ruby/pkg-config: add 1.5.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pkg-config')
-rw-r--r--dev-ruby/pkg-config/Manifest1
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.5.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/Manifest b/dev-ruby/pkg-config/Manifest
index c4d82fcff6f5..814965717c7a 100644
--- a/dev-ruby/pkg-config/Manifest
+++ b/dev-ruby/pkg-config/Manifest
@@ -1,2 +1,3 @@
DIST pkg-config-1.4.9.gem 22528 BLAKE2B 5b033292b56fd6cd163b611d3d16becb1489691ad348124234495333906eb19d92c994068a32416360248b641769f1da0aae777bf7372119d04ab9164cdd7b32 SHA512 b2052be243a6f9c9a96f76651f76460bbfd9d99fe5d1fa00f47683c659f2971ade525f5da5df49e214972f3cb1226d3212e134d44f1a3fcd5e0a8d253b281194
DIST pkg-config-1.5.1.gem 23040 BLAKE2B c814cabb2a57f9a40cd5b8112f0103a9aa7a4aeb10f2991ff23a846a98714d832c77ecb9bec9b3c884adf98496eb552451a6b98875a78921efdac229fc5a5e39 SHA512 972fdc1ed64adb66a388331e10c00648560abec8455727b804cb2fe9ce40dd9801dfc909116c1cc96b8617aa52873339a290c5d0775a88c30f2399566db557e6
+DIST pkg-config-1.5.2.gem 23040 BLAKE2B 32670e823980888b3cc679afa61cb71092b559ad12ab0cd4485ccc191353426af23f0007fd844cc8a71ad7c4c1c190587eb7643f19f68623ecad182270606141 SHA512 f4aa101ff6bbfce5bf23b6c83f61e186424c097f889e51fe337d158753fc8af26ee918bb509653ea70487a7d92a24b66cc96c1c0ea4bed2cfab5cd9380317679
diff --git a/dev-ruby/pkg-config/pkg-config-1.5.2.ebuild b/dev-ruby/pkg-config/pkg-config-1.5.2.ebuild
new file mode 100644
index 000000000000..d553cc41ba97
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/ruby-gnome/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+ sed -e '/test_cflags/aomit "Fragile on Gentoo"' -i test/test-pkg-config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test-pkg-config.rb || die
+}