summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rbpdf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rbpdf')
-rw-r--r--dev-ruby/rbpdf/Manifest1
-rw-r--r--dev-ruby/rbpdf/metadata.xml11
-rw-r--r--dev-ruby/rbpdf/rbpdf-1.18.6-r1.ebuild60
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-ruby/rbpdf/Manifest b/dev-ruby/rbpdf/Manifest
new file mode 100644
index 000000000000..a1181c85dec8
--- /dev/null
+++ b/dev-ruby/rbpdf/Manifest
@@ -0,0 +1 @@
+DIST rbpdf-1.18.6.gem 5764096 SHA256 d5d1e30ad1465bea5b3c1809cf2789c6795dafbfba6c2cab40c628989229b650 SHA512 a2c30082211d4b170c7cfea72f839541364d7e6b9da29b33a489a5900f63f2cc6ccb85c099ba2f090eec96c79c50026195f9a4a03c04274eea691188271b839b WHIRLPOOL 100c7ba0c7e21edf669d5a82ea8172f886dc9b804b4ecd93ae43b0baa25e3d2f15ce80f91cefa6b6400a0c829830780a3d7a4c7d9473895d25f2ba3720916107
diff --git a/dev-ruby/rbpdf/metadata.xml b/dev-ruby/rbpdf/metadata.xml
new file mode 100644
index 000000000000..eb4d92014860
--- /dev/null
+++ b/dev-ruby/rbpdf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <maintainer>
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">naitoh/rbpdf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rbpdf/rbpdf-1.18.6-r1.ebuild b/dev-ruby/rbpdf/rbpdf-1.18.6-r1.ebuild
new file mode 100644
index 000000000000..6f30463cd5ab
--- /dev/null
+++ b/dev-ruby/rbpdf/rbpdf-1.18.6-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ruby22 support waiting on dev-ruby/action{pack,view}.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# Avoid the complexity of the "rake" recipe and run the tests manually.
+RUBY_FAKEGEM_RECIPE_TEST=none
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby on Rails TCPDF plugin"
+HOMEPAGE="https://github.com/naitoh/rbpdf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Try to pick the right version of minitest. In order to run, the test
+# suite needs matching versions of actionview and activesupport. The
+# easiest way to do this is to pull them in simultaneously with
+# actionpack.
+ruby_add_bdepend "test? ( || (
+ ( dev-ruby/actionpack:3.2 dev-ruby/minitest:0 )
+ ( dev-ruby/actionpack:4.0 dev-ruby/minitest:0 )
+ ( dev-ruby/actionpack:4.1 dev-ruby/minitest:5 )
+ ( dev-ruby/actionpack:4.2 dev-ruby/minitest:5 )
+) )"
+
+# We need the action_view gem; it was split out of actionpack in 4.1.
+ruby_add_rdepend "|| (
+ dev-ruby/actionpack:3.2
+ dev-ruby/actionpack:4.0
+ dev-ruby/actionview:*
+)"
+
+all_ruby_prepare(){
+ default
+
+ # This test is enabled automagically in the presence of rmagick, and
+ # then fails.
+ rm -f test/rbpdf_image_rmagick_test.rb \
+ || die "failed to remove rmagick tests"
+}
+
+each_ruby_test() {
+ local cmd='gem "minitest"'
+ cmd+=' and '
+ cmd+='require "minitest/autorun"'
+ cmd+=' and '
+ cmd+='Dir["test/**/*_test.rb"].each{|f| require f}'
+ ${RUBY} -Ilib:.:test -e "${cmd}" || die "test suite failed"
+}