summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-12 06:23:20 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-12 06:23:20 +0200
commitfcf3a561a2e98d38cac2e235e53664d70e04ea7d (patch)
tree726f5a3cab8df1082d17e0b64896cc2da5e0f640 /dev-ruby/ruby-ldap
parentdev-ruby/dnsruby: add 1.61.0 (diff)
downloadgentoo-fcf3a561a2e98d38cac2e235e53664d70e04ea7d.tar.gz
gentoo-fcf3a561a2e98d38cac2e235e53664d70e04ea7d.tar.bz2
gentoo-fcf3a561a2e98d38cac2e235e53664d70e04ea7d.zip
dev-ruby/ruby-ldap: add 0.9.20
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/ruby-ldap')
-rw-r--r--dev-ruby/ruby-ldap/Manifest1
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ldap/Manifest b/dev-ruby/ruby-ldap/Manifest
index 3b0465a223c1..bc6ead88f213 100644
--- a/dev-ruby/ruby-ldap/Manifest
+++ b/dev-ruby/ruby-ldap/Manifest
@@ -1 +1,2 @@
DIST ruby-ldap-0.9.19.gem 91648 BLAKE2B 0ea6fe17ac2e4cd34a0834c6b95b1db4905e709010962959735cc3cedf9d50695d642b6042711b4f5154198fbe0bb5312903169ba8f1a7868b6f18d681a81682 SHA512 0ed931552df00c11855297ab44fd1c9a79e751937758d38189147f1d37cbce9b1da6fa42e64a9fd44610e948b1c13031013b7931ed473cd55b8425e64a50584a
+DIST ruby-ldap-0.9.20.gem 67072 BLAKE2B 626a35ab764dacfb37c727d867e1d435222730a3e7ea745ee4e7ec051ce3a822cc5a1230b463bc12f4a2390db667ed3b61deceb9842c014f64cdf43a26d285f9 SHA512 4f4902e7eaf4fe0cd421d58c73ce4e625d61ee20ef02363d3cf5754c66237e0f378ac433b234c2b86d5f5284ae03b7ae6c46d3575c512487bc1a931d021c9517
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild
new file mode 100644
index 000000000000..c52069c6d7ed
--- /dev/null
+++ b/dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+inherit multilib ruby-fakegem
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog FAQ NOTES README TODO"
+
+DESCRIPTION="A Ruby interface to some LDAP libraries"
+HOMEPAGE="https://github.com/bearded/ruby-ldap"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
+IUSE="ssl"
+DEPEND=">=net-nds/openldap-2
+ dev-libs/cyrus-sasl
+ ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+# Current test set is interactive due to certificate generation and requires
+# running LDAP daemon
+RESTRICT="test"
+
+each_ruby_configure() {
+ local myconf="--with-openldap2"
+ if ! use ssl ; then
+ myconf="${myconf} --without-libcrypto --without-libssl"
+ fi
+ ${RUBY} extconf.rb ${myconf} || die "extconf.rb failed"
+ sed -i -e 's:-Wl,--no-undefined::' \
+ -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" Makefile || die
+}
+
+each_ruby_compile() {
+ emake V=1
+ cp ldap$(get_modname) lib/ || die
+}