summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /dev-ruby/ruby-prof
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.18.0.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.18.0.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.18.0.ebuild
index 0bda0ee97519..d29eeb957fdb 100644
--- a/dev-ruby/ruby-prof/ruby-prof-0.18.0.ebuild
+++ b/dev-ruby/ruby-prof/ruby-prof-0.18.0.ebuild
@@ -47,7 +47,7 @@ each_ruby_configure() {
}
each_ruby_compile() {
- emake V=1 -Cext/ruby_prof || die "build failed"
+ emake V=1 -Cext/ruby_prof
cp ext/ruby_prof/*$(get_modname) lib/ || die "copy of extension failed"
}