summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-03-18 08:14:36 +0100
committerHans de Graaff <graaff@gentoo.org>2023-03-18 08:14:36 +0100
commit584e5622a79a476ccb78772eddb1d2d5b0e26c02 (patch)
tree231d608b2a5911d88d421b4bac73fc85130beeaa /dev-ruby/slop/slop-4.10.1.ebuild
parentdev-ruby/libusb: add extension installed marker manually (diff)
downloadgentoo-584e5622a79a476ccb78772eddb1d2d5b0e26c02.tar.gz
gentoo-584e5622a79a476ccb78772eddb1d2d5b0e26c02.tar.bz2
gentoo-584e5622a79a476ccb78772eddb1d2d5b0e26c02.zip
dev-ruby/slop: add 4.10.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/slop/slop-4.10.1.ebuild')
-rw-r--r--dev-ruby/slop/slop-4.10.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/slop/slop-4.10.1.ebuild b/dev-ruby/slop/slop-4.10.1.ebuild
new file mode 100644
index 000000000000..003a4bf68a9e
--- /dev/null
+++ b/dev-ruby/slop/slop-4.10.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="slop.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple option parser with an easy to remember syntax and friendly API"
+HOMEPAGE="https://github.com/leejarvis/slop"
+SRC_URI="https://github.com/leejarvis/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' slop.gemspec || die
+}