summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-06-16 07:10:04 +0200
committerHans de Graaff <graaff@gentoo.org>2019-06-16 08:37:54 +0200
commit61d90c18ff3d9cb6c202841cac10473da8b1f9e7 (patch)
tree6c1d1d98d1c8f7edf1cb7a69798859f7f3fce01b /dev-ruby/tty-cursor/tty-cursor-0.7.0.ebuild
parentdev-ruby/tty-screen: initial import of 0.7.0 (diff)
downloadgentoo-61d90c18ff3d9cb6c202841cac10473da8b1f9e7.tar.gz
gentoo-61d90c18ff3d9cb6c202841cac10473da8b1f9e7.tar.bz2
gentoo-61d90c18ff3d9cb6c202841cac10473da8b1f9e7.zip
dev-ruby/tty-cursor: initial import of 0.7.0
Dependency for forthcoming dev-ruby/tty-reader Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/tty-cursor/tty-cursor-0.7.0.ebuild')
-rw-r--r--dev-ruby/tty-cursor/tty-cursor-0.7.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/tty-cursor/tty-cursor-0.7.0.ebuild b/dev-ruby/tty-cursor/tty-cursor-0.7.0.ebuild
new file mode 100644
index 000000000000..560f169fc107
--- /dev/null
+++ b/dev-ruby/tty-cursor/tty-cursor-0.7.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Move the terminal cursor around and manipulate text using intuitive method calls"
+HOMEPAGE="https://github.com/piotrmurach/tty-cursor"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+}