summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-24 06:01:40 +0000
committerSam James <sam@gentoo.org>2022-12-24 06:31:51 +0000
commit0d62d2439ba82cff58a7ea15323844778b2833d1 (patch)
treeda2c39ffeb1ee6fb57b05a833851ee00757e3885 /dev-ruby/typhoeus
parentdev-ruby/typhoeus: fix faraday test dep (diff)
downloadgentoo-0d62d2439ba82cff58a7ea15323844778b2833d1.tar.gz
gentoo-0d62d2439ba82cff58a7ea15323844778b2833d1.tar.bz2
gentoo-0d62d2439ba82cff58a7ea15323844778b2833d1.zip
dev-ruby/typhoeus: depend on older dev-ruby/ethon
I've reported the failure upstream at https://github.com/typhoeus/typhoeus/issues/710 but I consistently get test failures with ethon-0.16.0 and they go away when I downgrade it to 0.15.0. Bug: https://github.com/typhoeus/typhoeus/issues/710 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/typhoeus')
-rw-r--r--dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild4
-rw-r--r--dev-ruby/typhoeus/typhoeus-1.4.0-r2.ebuild34
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild b/dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild
index b6c62ee9b3be..ffaf7dcb9362 100644
--- a/dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild
+++ b/dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild
@@ -21,7 +21,9 @@ SLOT="1"
KEYWORDS="~amd64"
IUSE=""
-ruby_add_rdepend ">=dev-ruby/ethon-0.9.0"
+# Tests fail with ethon-0.16.0
+# https://github.com/typhoeus/typhoeus/issues/710
+ruby_add_rdepend "<dev-ruby/ethon-0.16.0"
ruby_add_bdepend "test? ( dev-ruby/json || ( dev-ruby/faraday:1 >=dev-ruby/faraday-0.9:0 ) >=dev-ruby/sinatra-1.3 >=dev-ruby/redis-3.0 >=dev-ruby/dalli-2.7.9 )"
diff --git a/dev-ruby/typhoeus/typhoeus-1.4.0-r2.ebuild b/dev-ruby/typhoeus/typhoeus-1.4.0-r2.ebuild
new file mode 100644
index 000000000000..ffaf7dcb9362
--- /dev/null
+++ b/dev-ruby/typhoeus/typhoeus-1.4.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md UPGRADE.md"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Runs HTTP requests in parallel while cleanly encapsulating handling logic"
+HOMEPAGE="https://rubygems.org/gems/typhoeus/
+ https://github.com/typhoeus/typhoeus"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Tests fail with ethon-0.16.0
+# https://github.com/typhoeus/typhoeus/issues/710
+ruby_add_rdepend "<dev-ruby/ethon-0.16.0"
+
+ruby_add_bdepend "test? ( dev-ruby/json || ( dev-ruby/faraday:1 >=dev-ruby/faraday-0.9:0 ) >=dev-ruby/sinatra-1.3 >=dev-ruby/redis-3.0 >=dev-ruby/dalli-2.7.9 )"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die
+ sed -i -e '3igem "faraday", "<2"; require "timeout"' spec/spec_helper.rb || die
+ sed -i -e '/Rack::Handler::WEBrick/ s/options/\*\*options/' spec/support/localhost_server.rb || die
+}